Dead Links from Forum to Documentation pages

I’ve found that many links to documentation Pages are broken, as Virtualmin-Admins change the url-schema.

For example:
https://www.virtualmin.com/os-support.html
becomes:
https://www.virtualmin.com/os-support/

Would be nice, if the Webmaster of the Virtualmin-Docu-Page could generate an redirect from those old schemed files to the “non-trailing-.html” ones, to fix this completely for the whole forum.

Thanks in advanced.

Or you could just click the ‘Documentation’ link at the top of the page and they’re all right there for you.

When they migrated over to Discourse from the old platform it caused some issues. That’s why they completely redid the Documentation page.

https://www.virtualmin.com/os-support/

Ok, but this is not a solution.
Be honest! If somebody link in his answer to a documentation-page, do you want to get to an error-page.
Sure you can start by searching via the Search-Field at the documentation-page… but this isn’t really handy. And it’s not the idea of an forum.

It’s easy like 1,2,3 to add a short .htaccess-rewrite to fix this for the whole links in the forum (even for SEO with a 302 redirect). So why should they force everybody to land on broken pages and search for the right link. I don’t see why you argument against this.

I think they still not noticed, that this issue occur, and that’s the only reason, why this still happens.

I guess it’s that I understand all the work they’ve had to put into the move because not everything made it in one go. They’ve been working on it for months as well as the ongoing work on Virtualmin 7.

I’d rather find a link with relative ease on my own and have them concentrate on V7.

But that’s just me. I’m pretty self sufficient that way. Especially when all I have to do is delete the .html from the address because I know the new site is PHP based.

I honor and appreciate all the hard work - and that never was questioned in this thread.
I think all stuff we written here is much more effort as creating a single line in an htaccess-file. :wink:

Don’t let waste more time and don’t blow up this thread, only let the VM-Webdevs decide what they’ll do.

@suther,

Where are you seeing the old links?

I may be able to help as I do have access to adding and adjusting the documents on Virtualmin.com.

If I cannot be of direct help, I may be able to suggest something to Joe who does most of the website management about a possible workaround.

@Gomez_Adams, the documentation was not done as a result of Discourse being introduced, but as a result of the site moving from Drupal to WordPress.

1 Like

there is no webmaster guys, it’s only team of 4 people behind all of this. I mean virtualmin, website, development etc… despite this I think they did and continue to do mega awesome job.

Anyway I did offered solution for couple times or more… and I guess it was not good enough :thinking: who knows. Simple fix would be crawl all links and found out which are broken, then just add 301 redirects to htaccess… or move docs to central git repo somewhere and let people contribute of course with appropriate approvals from fantastic 4… I don’t know…

I stopped nagging them about it as I always end up in dead end. just created my own updated version of what I needed and focused energy where it’s needed :wink:

there is no webmaster guys, it’s only team of 4 people behind all of this. I mean virtualmin, website, development etc… despite this I think they did and continue to do mega awesome job.

Didn’t know that. So honor to this team. You produce awesome results!

@tpnsolutions
I like to use tools like those link-checkers to find all occurrences of broken links: Broken Link Checker Tool - Dead Link Checker

In my case I found

  1. many in SEO-Results (DuckDuckGo.com - e.g. Search for virtualmin contribute… but there many other old, dead SEO-Links)
  2. An example in a Thread here in the forum: Enable Multiple PHP Version on AmazonLinux - #3 by Abhijeet_Gaikwad
  3. you also can search via google for: inanchor: www.virtualmin.com/os-support.html site:forum.virtualmin.com - Google Search

This should fix it

What you need is to redirect old .html page to new direction, without .html.

To archive that, add following to the .htaccess file in your document root… right before your wordpress rules:

ONE-LINER:

RedirectMatch 301  ^/(.*)\.html$ /$1

Or if you need it limited by host:

RewriteCond %{HTTP_HOST} virtualmin.com [NC]
RewriteRule ^(.*)\.html$ /$1 [R=301,L]
2 Likes

We could do that. That is easy.

Although, there were other redirect issues that were just discovered that needed addressing.

All fixed now.

Thanks for reporting!

If you have figured out, which kind of re-direct error it is, I might give helping hand to fix them… as you guys still have to work hard on Version 7 of virtualmin.

Thanks, we’re good. All should work now. Give it a try.

1 Like