DBI connect failed : Access denied for user 'root'@'localhost' to database 'mysql'

I am getting error message like this :

DBI connect failed : Access denied for user ‘root’@‘localhost’ to database ‘mysql’

i am unable to add new VPS server or delete any Vps server .

unable to add new user or delete any thing everytime when i do this get error message like this.

DBI connect failed : Access denied for user ‘root’@‘localhost’ to database ‘mysql’

please help me what i done wrong ??

recently i restore backups !! from my backups.

thank you.
aryan

Howdy,

Try going into Webmin -> Servers -> MySQL -> Module Config, and there, set “Administration password” to your correct root MySQL password.

If that doesn’t work – did you perhaps change to a non-standard MySQL version recently, such as one from a third party repository?

-Eric

tried but not worked ,

i have in my memory what is password , i didn’t forget it so not required to change.

if i change in the method you just told it not getting login with new password , only works with my old mysql password .

error message still there

my mysql password is correct and working fine in SSH and webmin mysql login but only getting this error.

unable to delete a server or create same error coming.

Did you perhaps change to a non-standard MySQL version recently, such as one from a third party repository?

Also, what distro/version are you using?

-Eric

hello,

check if /root/.my.cnf exist, it might be the problem

its say No such files in directory

No, i didn’t change mysql
only i did , i migrate this current server to a new VPS server by backup this server and restore to new VPS ,

after that i delete this server ,

after someday i just restore data backup to this server from that backup data file , after that problem started .

any idea??

also a new problem with my new VPS i am not able to loging via FTP . error message is connection REFUSE !! i restore this server from my old one.

What distro/version is it that you’re using?

-Eric

4.06.gpl centOS Linux 6.5

Okay, and what is the output of this command:

rpm -qa | grep mysql

is is asking for password and when i put my mysql password : access denied !!

The command Eric asked you to execute has nothing to do with MySQL, it’s a call to “rpm”, the CentOS package manager. It should not ask you for a password, and you should not need the MySQL root password there!

[root@bb ~]# rpm -qa
gnupg2-2.0.14-6.el6_4.x86_64
libxslt-1.1.26-2.el6_3.1.x86_64
basesystem-10.0-4.el6.noarch
man-1.6f-32.el6.x86_64
perl-Net-LibIDN-0.12-3.el6.x86_64
authconfig-6.1.12-13.el6.x86_64
libattr-2.4.44-7.el6.x86_64
wget-1.12-1.11.el6_5.x86_64
perl-Digest-HMAC-1.01-22.el6.noarch
mod_fcgid-2.3.9-1.el6.x86_64
readline-6.0-4.el6.x86_64
libXrender-0.9.7-2.el6.x86_64
ruby-1.8.7.352-13.el6.x86_64
popt-1.13-7.el6.x86_64
libXrandr-1.4.0-1.el6.x86_64
python-libs-2.6.6-52.el6.x86_64
libgpg-error-1.7-4.el6.x86_64
atk-1.30.0-1.el6.x86_64
libproxy-0.3.0-4.el6_3.x86_64
libidn-1.18-2.el6.x86_64
cups-libs-1.4.2-50.el6_4.5.x86_64
net-snmp-5.5-49.el6.x86_64
libXtst-1.2.1-2.el6.x86_64
perl-DBD-MySQL-4.013-3.el6.x86_64
libXft-2.3.1-2.el6.x86_64
perl-Net-SSLeay-1.35-9.el6.x86_64
gettext-0.17-16.el6.x86_64
libc-client-2007e-11.el6.x86_64
ncurses-5.7-3.20090208.el6.x86_64
libgfortran-4.4.7-4.el6.x86_64
libXau-1.0.6-4.el6.x86_64
cairo-1.8.8-3.1.el6.x86_64
perl-Time-HiRes-1.9721-136.el6.x86_64
libart_lgpl-2.3.20-5.1.el6.x86_64
perl-MailTools-2.04-4.el6.noarch
kernel-devel-2.6.32-431.11.2.el6.x86_64
keyutils-libs-1.4-4.el6.x86_64
mod_dav_svn-1.6.11-10.el6_5.x86_64
perl-XML-Parser-2.36-7.el6.x86_64
swig-1.3.40-6.el6.x86_64
glibc-devel-2.12-1.132.el6.x86_64
flex-2.5.35-8.el6.x86_64
perl-Test-Harness-3.17-136.el6.x86_64
cscope-15.6-6.el6.x86_64
libX11-1.5.0-4.el6.x86_64
python-pycurl-7.19.0-8.el6.x86_64
glib2-2.26.1-7.el6_5.x86_64
php-gd-5.3.3-27.el6_5.x86_64
sgml-common-0.6.3-32.el6.noarch
docbook-dtds-1.0-51.el6.noarch
mod_ssl-2.2.15-29.el6.vm.1.x86_64
shadow-utils-4.1.4.2-13.el6.x86_64
libxml2-devel-2.7.6-14.el6.x86_64
tcp_wrappers-libs-7.6-57.el6.x86_64
openjade-1.3.2-36.el6.x86_64
php-pear-1.9.4-4.el6.noarch
atk-devel-1.30.0-1.el6.x86_64
php-pgsql-5.3.3-27.el6_5.x86_64
libuser-0.56.13-5.el6.x86_64
libXrender-devel-0.9.7-2.el6.x86_64
dovecot-2.0.9-7.el6.x86_64
bzip2-1.0.5-7.el6_0.x86_64
libXcursor-devel-1.1.13-6.20130524git8f677eaea.el6.x86_64
cyrus-sasl-gssapi-2.1.23-13.el6_3.1.x86_64
libXft-devel-2.3.1-2.el6.x86_64
php-xmlrpc-5.3.3-27.el6_5.x86_64
libnih-1.0.1-7.el6.x86_64
polkit-0.96-5.el6_4.x86_64
mingetty-1.08-5.el6.x86_64
libsoup-2.28.2-4.el6.x86_64
wbm-virtualmin-svn-5.0-1.noarch
libusb-0.1.12-23.el6.x86_64
glib-1.2.10-33.el6.x86_64
wbm-virtualmin-init-2.4-1.noarch
newt-0.52.11-3.el6.x86_64
cdparanoia-libs-10.2-5.1.el6.x86_64
wbm-php-pear-1.5-1.noarch
pango-devel-1.28.1-7.el6_3.x86_64
docbook-utils-0.6.14-25.el6.noarch
gstreamer-devel-0.10.29-1.el6.x86_64
procmail-wrapper-1.0-1.vm.x86_64
xz-4.999.9-0.3.beta.20091007git.el6.x86_64
NetworkManager-glib-0.8.1-66.el6.x86_64
epel-release-6-8.noarch
kbd-misc-1.15-11.el6.noarch
libgcrypt-devel-1.4.5-11.el6_4.x86_64
cpp-4.4.7-4.el6.x86_64
libvorbis-1.2.3-4.el6_2.1.x86_64
libgomp-4.4.7-4.el6.x86_64
webkitgtk-1.2.6-5.el6.x86_64
automake-1.11.1-4.el6.noarch
wireless-tools-29-5.1.1.el6.x86_64
gtk±1.2.10-70.el6.x86_64
gpg-pubkey-0608b895-4bd22942
libtdb-1.2.10-1.el6.x86_64
nss-util-3.15.3-1.el6_5.x86_64
system-config-network-tui-1.6.0.el6.2-1.el6.noarch
enca-devel-1.13-1.el6.x86_64
nss-softokn-freebl-3.14.3-9.el6.x86_64
libsndfile-1.0.20-5.el6.x86_64
cpio-2.10-11.el6_3.x86_64
libasyncns-0.8-1.1.el6.x86_64
libblkid-2.17.2-12.14.el6.x86_64
xcb-util-0.3.6-1.el6.x86_64
grep-2.6.3-4.el6.x86_64
libnotify-0.5.0-1.el6.x86_64
plymouth-scripts-0.8.3-27.el6.centos.x86_64
rootfiles-8.1-6.1.el6.noarch
libass-devel-0.10.0-1.el6.x86_64
setup-2.8.14-20.el6_4.1.noarch
openssl-devel-1.0.1e-16.el6_5.7.x86_64
shared-mime-info-0.70-4.el6.x86_64
nss-3.15.3-6.el6_5.x86_64
libcurl-7.19.7-37.el6_4.x86_64
rpm-python-4.8.0-37.el6.x86_64
tar-1.23-11.el6.x86_64
perl-libs-5.10.1-136.el6.x86_64
module-init-tools-3.9-21.el6_4.x86_64
perl-5.10.1-136.el6.x86_64
iproute-2.6.32-31.el6.x86_64
gpg-pubkey-ef1d6db8-4e0fd7f0
dhcp-common-4.1.1-38.P1.el6.centos.x86_64
glibc-common-2.12-1.132.el6.x86_64
plymouth-core-libs-0.8.3-27.el6.centos.x86_64
db4-4.7.25-18.el6_4.x86_64
procps-3.2.8-25.el6.x86_64
apr-1.3.9-5.el6_2.x86_64
udev-147-2.51.el6.x86_64
cyrus-sasl-lib-2.1.23-13.el6_3.1.x86_64
libdrm-2.4.45-2.el6.x86_64
perl-URI-1.40-2.el6.noarch
postgresql-8.4.20-1.el6_5.x86_64
libjpeg-turbo-1.2.1-3.el6_5.x86_64
cronie-1.4.4-12.el6.x86_64
perl-IO-Compress-Zlib-2.021-136.el6.x86_64
openssh-clients-5.3p1-94.el6.x86_64
zlib-devel-1.2.3-29.el6.x86_64
mysql-server-5.1.73-3.el6_5.x86_64
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
e2fsprogs-1.41.12-18.el6.x86_64
filesystem-2.4.30-3.el6.x86_64
pakchois-0.4-3.2.el6.x86_64
db4-devel-4.7.25-18.el6_4.x86_64
perl-Digest-SHA-5.47-136.el6.x86_64
libtasn1-2.3-3.el6_2.1.x86_64
libtool-ltdl-2.2.6-15.5.el6.x86_64
libcap-2.16-5.5.el6.x86_64
perl-Digest-SHA1-2.12-2.el6.x86_64
info-4.13a-8.el6.x86_64
perl-Net-DNS-0.65-5.el6.x86_64
make-3.81-20.el6.x86_64
bzip2-libs-1.0.5-7.el6_0.x86_64
sqlite-3.6.20-1.el6.x86_64
ruby-libs-1.8.7.352-13.el6.x86_64
libXext-1.3.1-2.el6.x86_64
lua-5.1.4-4.1.el6.x86_64
libXfixes-5.0-3.el6.x86_64
python-2.6.6-52.el6.x86_64
elfutils-libelf-0.152-1.el6.x86_64
libXi-1.6.1-3.el6.x86_64
bind-libs-9.8.2-0.23.rc1.el6_5.1.x86_64
patch-2.6-6.el6.x86_64
libproxy-bin-0.3.0-4.el6_3.x86_64
perl-Error-0.17015-4.el6.noarch
libproxy-python-0.3.0-4.el6_3.x86_64
pth-2.0.7-9.3.el6.x86_64
libtiff-3.9.4-10.el6_5.x86_64
gmp-4.3.1-7.el6_2.2.x86_64
perl-Git-1.7.1-3.el6_4.1.noarch
ruby-irb-1.8.7.352-13.el6.x86_64
libSM-1.2.1-2.el6.x86_64
libXdamage-1.1.3-4.el6.x86_64
perl-Crypt-OpenSSL-Bignum-0.04-8.1.el6.x86_64
libXinerama-1.1.2-2.el6.x86_64
perl-Crypt-OpenSSL-RSA-0.25-10.1.el6.x86_64
libsepol-2.0.41-4.el6.x86_64
jasper-libs-1.900.1-15.el6_1.1.x86_64
perl-IO-Socket-SSL-1.31-2.el6.noarch
gamin-0.1.10-9.el6.x86_64
cvs-1.11.23-16.el6.x86_64
httpd-2.2.15-29.el6.vm.1.x86_64
sed-4.2.1-10.el6.x86_64
gdb-7.2-60.el6_4.1.x86_64
tcp_wrappers-7.6-57.el6.x86_64
audit-libs-2.2-2.el6.x86_64
gettext-libs-0.17-16.el6.x86_64
perl-IO-Socket-INET6-2.56-4.el6.noarch
less-436-10.el6.x86_64
alsa-lib-1.0.22-3.el6.x86_64
libxcb-1.8.1-1.el6.x86_64
pixman-0.26.2-5.1.el6_5.x86_64
iptables-1.4.7-11.el6.x86_64
cracklib-dicts-2.8.16-4.el6.x86_64
libthai-0.1.12-3.el6.x86_64
procmail-3.22-25.1.el6.x86_64
gtk2-2.20.1-4.el6.x86_64
perl-TimeDate-1.16-11.1.el6.noarch
libgcj-4.4.7-4.el6.x86_64
perl-Mail-DKIM-0.37-2.el6.noarch
subversion-1.6.11-10.el6_5.x86_64
krb5-devel-1.10.3-10.el6_4.6.x86_64
gdbm-1.8.0-36.el6.x86_64
systemtap-devel-2.3-4.el6_5.x86_64
perl-HTML-Tagset-3.20-4.el6.noarch
systemtap-2.3-4.el6_5.x86_64
perl-libwww-perl-5.833-2.el6.noarch
intltool-0.41.0-1.1.el6.noarch
gdbm-devel-1.8.0-36.el6.x86_64
rpm-build-4.8.0-37.el6.x86_64
glibc-headers-2.12-1.132.el6.x86_64
redhat-rpm-config-9.0.3-42.el6.centos.noarch
perl-ExtUtils-ParseXS-2.2003.0-136.el6.x86_64
rcs-5.7-37.el6.x86_64
perl-devel-5.10.1-136.el6.x86_64
patchutils-0.3.1-3.1.el6.x86_64
perl-Package-Constants-0.02-136.el6.x86_64
byacc-1.9.20070509-7.el6.x86_64
libX11-common-1.5.0-4.el6.noarch
pygpgme-0.1-18.20090824bzr68.el6.x86_64
ctags-5.8-2.el6.x86_64
libXpm-3.5.10-2.el6.x86_64
bison-2.4.1-5.el6.x86_64
webalizer-2.21_02-3.3.el6.x86_64
yum-metadata-parser-1.1.2-16.el6.x86_64
xorg-x11-proto-devel-7.6-25.el6.noarch
spamassassin-3.3.1-3.el6.x86_64
dbus-1.2.24-7.el6_3.x86_64
perl-XML-Simple-2.18-6.el6.noarch
gpg-pubkey-c105b9de-4e0fd3a3
freetype-devel-2.3.11-14.el6_3.1.x86_64
iptables-ipv6-1.4.7-11.el6.x86_64
xml-common-0.6.3-32.el6.noarch
php-imap-5.3.3-27.el6_5.x86_64
libicu-4.2.1-9.1.el6_2.x86_64
mailman-2.1.12-18.el6.x86_64
gnutls-2.8.5-13.el6_5.x86_64
fipscheck-lib-1.2.0-7.el6.x86_64
docbook-style-xsl-1.75.2-6.el6.noarch
opensp-1.5.2-12.1.el6.x86_64
php-snmp-5.3.3-27.el6_5.x86_64
perl-SGMLSpm-1.03ii-21.el6.noarch
bind-utils-9.8.2-0.23.rc1.el6_5.1.x86_64
ConsoleKit-libs-0.4.1-3.el6.x86_64
ruby-devel-1.8.7.352-13.el6.x86_64
findutils-4.4.2-6.el6.x86_64
libXau-devel-1.0.6-4.el6.x86_64
perl-DBD-Pg-2.15.1-4.el6_3.x86_64
libX11-devel-1.5.0-4.el6.x86_64
perl-Crypt-SSLeay-0.57-16.el6.x86_64
checkpolicy-2.0.22-1.el6.x86_64
libXext-devel-1.3.1-2.el6.x86_64
cyrus-sasl-2.1.23-13.el6_3.1.x86_64
passwd-0.77-4.el6_2.2.x86_64
libXcomposite-devel-0.4.3-4.el6.x86_64
php-xml-5.3.3-27.el6_5.x86_64
libXrandr-devel-1.4.0-1.el6.x86_64
logrotate-3.7.8-17.el6.x86_64
system-config-firewall-base-1.2.27-5.el6.noarch
libXinerama-devel-1.1.2-2.el6.x86_64
php-mbstring-5.3.3-27.el6_5.x86_64
libIDL-0.8.13-2.1.el6.x86_64
db4-utils-4.7.25-18.el6_4.x86_64
eggdbus-0.6-3.el6.x86_64
webmin-1.675-1.noarch
libutempter-1.1.5-4.1.el6.x86_64
ConsoleKit-0.4.1-3.el6.x86_64
usermin-1.570-1.noarch
libedit-2.11-4.20080712cvs.1.el6.x86_64
gnome-keyring-2.28.2-8.el6_3.x86_64
wbm-virtualmin-mailman-6.2-1.noarch
gstreamer-tools-0.10.29-1.el6.x86_64
wbm-virtualmin-awstats-4.9-1.noarch
libXv-1.0.7-2.el6.x86_64
wbt-virtual-server-mobile-2.5-1.noarch
slang-2.2.1-1.el6.x86_64
rarian-0.8.1-5.1.el6.x86_64
wbm-virtualmin-registrar-2.2-1.noarch
newt-python-0.52.11-3.el6.x86_64
liboil-0.3.16-4.1.el6.x86_64
wbt-virtual-server-theme-8.7-1.noarch
libXt-1.1.3-1.el6.x86_64
wbm-virtualmin-htpasswd-2.6-1.noarch
libcap-ng-0.6.4-3.el6_0.1.x86_64
cyrus-sasl-plain-2.1.23-13.el6_3.1.x86_64
net-tools-1.60-110.el6_2.x86_64
cyrus-sasl-md5-2.1.23-13.el6_3.1.x86_64
ustr-1.0.4-9.1.el6.x86_64
m4-1.4.13-5.el6.x86_64
perl-IO-Tty-1.08-4.el6.x86_64
xz-lzma-compat-4.999.9-0.3.beta.20091007git.el6.x86_64
virtualmin-base-1.0-63.rh.noarch
libgcc-4.4.7-4.el6.x86_64
diffutils-2.8.1-28.el6.x86_64
mpfr-2.4.1-6.el6.x86_64
libstdc+±devel-4.4.7-4.el6.x86_64
usermode-1.102-3.el6.x86_64
autoconf-2.63-5.1.el6.noarch
crda-1.1.1_2010.11.22-1.el6.x86_64
libtool-2.2.6-15.5.el6.x86_64
python-iwlib-0.1-1.2.el6.x86_64
crontabs-1.10-33.el6.noarch
kbd-1.15-11.el6.x86_64
system-config-firewall-tui-1.2.27-5.el6.noarch
audit-2.2-2.el6.x86_64
lsof-4.82-4.el6.x86_64
which-2.19-6.el6.x86_64
nano-2.0.9-7.el6.x86_64
uuid-1.6.1-10.el6.x86_64
attr-2.4.44-7.el6.x86_64
kernel-2.6.32-279.el6.x86_64
perl-Pod-Escapes-1.04-136.el6.x86_64
perl-Pod-Simple-3.13-136.el6.x86_64
perl-Module-Pluggable-3.90-136.el6.x86_64
gpg-pubkey-fe837f6f-4e0fd77e
gpg-pubkey-a0bdbcf9-42d1d837
glibc-2.12-1.132.el6.x86_64
libcom_err-1.41.12-18.el6.x86_64
php-common-5.3.3-27.el6_5.x86_64
krb5-libs-1.10.3-10.el6_4.6.x86_64
apr-util-1.3.9-3.el6_0.1.x86_64
php-pdo-5.3.3-27.el6_5.x86_64
libpng-1.2.49-1.el6_2.x86_64
freetype-2.3.11-14.el6_3.1.x86_64
e2fsprogs-libs-1.41.12-18.el6.x86_64
portreserve-0.0.4-9.el6.x86_64
lm_sensors-libs-3.1.1-17.el6.x86_64
mailcap-2.1.31-2.el6.noarch
perl-Compress-Zlib-2.021-136.el6.x86_64
fontconfig-2.8.0-3.el6.x86_64
libsepol-devel-2.0.41-4.el6.x86_64
libcom_err-devel-1.41.12-18.el6.x86_64
dhclient-4.1.1-38.P1.el6.centos.x86_64
pciutils-3.1.10-2.el6.x86_64
ca-certificates-2013.1.95-65.1.el6_5.noarch
sudo-1.8.6p3-12.el6.x86_64
grub-0.97-83.el6.x86_64
python-ethtool-0.6-5.el6.x86_64
virtualmin-release-1.0-5.gpl.rhel.noarch
wbm-virtual-server-4.06.gpl-1.noarch
kernel-headers-2.6.32-431.5.1.el6.x86_64
rsync-3.0.6-9.el6_4.1.x86_64
tzdata-2013i-2.el6.noarch
cairo-devel-1.8.8-3.1.el6.x86_64
gtk2-devel-2.20.1-4.el6.x86_64
lynx-2.8.6-27.el6.x86_64
gtk-doc-1.11-5.1.el6.noarch
check-devel-0.9.8-1.1.el6.x86_64
libvisual-0.4.0-9.1.el6.x86_64
libgudev1-147-2.51.el6.x86_64
geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64
libgpg-error-devel-1.7-4.el6.x86_64
gnutls-devel-2.8.5-13.el6_5.x86_64
libtheora-1.1.0-2.el6.x86_64
cloog-ppl-0.15.7-1.2.el6.x86_64
gstreamer-plugins-base-0.10.29-2.el6.x86_64
gcc-4.4.7-4.el6.x86_64
enchant-1.5.0-4.el6.x86_64
webkitgtk-devel-1.2.6-5.el6.x86_64
fribidi-devel-0.19.2-2.el6.x86_64
livna-release-1-1.noarch
yasm-1.2.0-1.el6.x86_64
bash-4.1.2-15.el6_4.x86_64
dbus-devel-1.2.24-7.el6_3.x86_64
nspr-4.10.2-1.el6_5.x86_64
libogg-devel-1.1.4-2.1.el6.x86_64
mysql-libs-5.1.73-3.el6_5.x86_64
libass-0.10.0-1.el6.x86_64
file-libs-5.04-15.el6.x86_64
dbus-glib-devel-0.86-6.el6.x86_64
dbus-libs-1.2.24-7.el6_3.x86_64
flac-1.2.1-6.1.el6.x86_64
p11-kit-0.18.5-2.el6_5.2.x86_64
libsamplerate-0.1.7-2.1.el6.x86_64
libsemanage-2.0.43-4.2.el6.x86_64
sound-theme-freedesktop-0.7-3.el6.noarch
libuuid-2.17.2-12.14.el6.x86_64
pulseaudio-libs-0.9.21-14.el6_3.x86_64
libssh2-1.4.2-1.el6.x86_64
libcanberra-gtk2-0.22-1.el6.centos.x86_64
pcre-7.8-6.el6.x86_64
startup-notification-0.10-2.1.el6.x86_64
coreutils-libs-8.4-31.el6.x86_64
notification-daemon-0.5.0-1.el6.x86_64
pam-1.1.1-17.el6.x86_64
libnotify-devel-0.5.0-1.el6.x86_64
redhat-logos-60.0.14-12.el6.centos.noarch
libgudev1-devel-147-2.51.el6.x86_64
gzip-1.3.12-19.el6_4.x86_64
libtheora-devel-1.1.0-2.el6.x86_64
psmisc-22.6-19.el6_5.x86_64
openssl-1.0.1e-16.el6_5.7.x86_64
dbus-glib-0.86-6.el6.x86_64
nss-sysinit-3.15.3-6.el6_5.x86_64
nss-tools-3.15.3-6.el6_5.x86_64
postgresql-libs-8.4.20-1.el6_5.x86_64
curl-7.19.7-37.el6_4.x86_64
rpm-4.8.0-37.el6.x86_64
p11-kit-trust-0.18.5-2.el6_5.2.x86_64
file-5.04-15.el6.x86_64
clamav-db-0.98.1-1.el6.x86_64
binutils-2.20.51.0.2-5.36.el6.x86_64
hwdata-0.233-9.1.el6.noarch
dash-0.5.5.1-4.el6.x86_64
kernel-firmware-2.6.32-431.5.1.el6.noarch
pciutils-libs-3.1.10-2.el6.x86_64
GeoIP-1.4.8-1.el6.x86_64
libgcrypt-1.4.5-11.el6_4.x86_64
python-urlgrabber-3.9.1-9.el6.noarch
yum-3.2.29-43.el6.centos.noarch
iputils-20071127-17.el6_4.2.x86_64
initscripts-9.03.40-2.el6.centos.1.x86_64
openssh-5.3p1-94.el6.x86_64
selinux-policy-3.7.19-231.el6.noarch
plymouth-0.8.3-27.el6.centos.x86_64
dracut-kernel-004-336.el6_5.2.noarch
rsyslog-5.8.10-8.el6.x86_64
cronie-anacron-1.4.4-12.el6.x86_64
postgresql-server-8.4.20-1.el6_5.x86_64
selinux-policy-targeted-3.7.19-231.el6.noarch
openssh-server-5.3p1-94.el6.x86_64
proftpd-1.3.3g-4.el6.x86_64
xinetd-2.3.14-39.el6_4.x86_64
libss-1.41.12-18.el6.x86_64
clamd-0.98.1-1.el6.x86_64
db4-cxx-4.7.25-18.el6_4.x86_64
ncurses-base-5.7-3.20090208.el6.x86_64
mysql-devel-5.1.73-3.el6_5.x86_64
perl-BSD-Resource-1.29.03-3.el6.x86_64
ncurses-libs-5.7-3.20090208.el6.x86_64
iw-3.10-1.1.el6.x86_64
unixODBC-2.2.14-12.el6_3.x86_64
stunnel-4.29-3.el6_4.x86_64
compat-readline5-5.2-17.1.el6.x86_64
setuptool-1.19.9-4.el6.x86_64
libacl-2.2.49-6.el6.x86_64
avahi-libs-0.6.25-12.el6.x86_64
net-snmp-libs-5.5-49.el6.x86_64
libICE-1.0.6-1.el6.x86_64
php-cli-5.3.3-27.el6_5.x86_64
xz-libs-4.999.9-0.3.beta.20091007git.el6.x86_64
zip-3.0-1.el6.x86_64
neon-0.29.3-3.el6_4.x86_64
git-1.7.1-3.el6_4.1.x86_64
ruby-rdoc-1.8.7.352-13.el6.x86_64
pinentry-0.7.6-6.el6.x86_64
libXcursor-1.1.13-6.20130524git8f677eaea.el6.x86_64
perl-Crypt-OpenSSL-Random-0.04-9.1.el6.x86_64
hicolor-icon-theme-0.11-1.1.el6.noarch
httpd-tools-2.2.15-29.el6.vm.1.x86_64
systemtap-runtime-2.3-4.el6_5.x86_64
perl-Socket6-0.23-4.el6.x86_64
groff-1.18.1.4-21.el6.x86_64
libXcomposite-0.4.3-4.el6.x86_64
perl-NetAddr-IP-4.027-7.el6.x86_64
cracklib-2.8.16-4.el6.x86_64
pango-1.28.1-7.el6_3.x86_64
perl-Encode-Detect-1.01-2.el6.x86_64
gettext-devel-0.17-16.el6.x86_64
keyutils-libs-devel-1.4-4.el6.x86_64
expat-2.0.1-11.el6_2.x86_64
systemtap-client-2.3-4.el6_5.x86_64
perl-HTML-Parser-3.64-2.el6.x86_64
libffi-3.0.5-3.2.el6.x86_64
gcc-gfortran-4.4.7-4.el6.x86_64
indent-2.2.10-7.el6.x86_64
perl-ExtUtils-MakeMaker-6.55-136.el6.x86_64
doxygen-1.6.1-6.el6.x86_64
perl-Archive-Tar-1.58-136.el6.x86_64
gpgme-1.1.8-3.el6.x86_64
diffstat-1.51-2.el6.x86_64
gd-2.0.35-11.el6.x86_64
python-iniparse-0.3.1-2.1.el6.noarch
glib2-devel-2.26.1-7.el6_5.x86_64
mod_perl-2.0.4-10.el6.x86_64
fontconfig-devel-2.8.0-3.el6.x86_64
quota-3.17-20.el6.x86_64
libpng-devel-1.2.49-1.el6_2.x86_64
php-5.3.3-27.el6_5.x86_64
fipscheck-1.2.0-7.el6.x86_64
iso-codes-3.16-2.el6.noarch
rubygems-1.3.7-5.el6.noarch
docbook-style-dsssl-1.79-10.el6.noarch
bind-9.8.2-0.23.rc1.el6_5.1.x86_64
libxcb-devel-1.8.1-1.el6.x86_64
php-mysql-5.3.3-27.el6_5.x86_64
libXfixes-devel-5.0-3.el6.x86_64
php-odbc-5.3.3-27.el6_5.x86_64
dbus-python-0.83.0-6.1.el6.x86_64
libXi-devel-1.6.1-3.el6.x86_64
libselinux-utils-2.0.94-5.3.el6_4.1.x86_64
ORBit2-2.14.17-3.2.el6_3.x86_64
mlocate-0.22.2-4.el6.x86_64
MAKEDEV-3.24-6.el6.x86_64
GConf2-2.28.0-6.el6.x86_64
ust-virtual-server-theme-6.9-1.noarch
vim-minimal-7.2.411-1.8.el6.x86_64
gstreamer-0.10.29-1.el6.x86_64
wbm-virtualmin-dav-3.5-1.noarch
rarian-compat-0.8.1-5.1.el6.x86_64
wbm-ruby-gems-1.4-1.noarch
pixman-devel-0.26.2-5.1.el6_5.x86_64
wbm-security-updates-4.4-1.noarch
centos-indexhtml-6-1.el6.centos.noarch
check-0.9.8-1.1.el6.x86_64
libudev-147-2.51.el6.x86_64
scponly-4.8-6.el6.x86_64
elfutils-libs-0.152-1.el6.x86_64
fribidi-0.19.2-2.el6.x86_64
libstdc+±4.4.7-4.el6.x86_64
libsoup-devel-2.28.2-4.el6.x86_64
ppl-0.10.2-11.el6.x86_64
hunspell-1.2.8-16.el6.x86_64
gcc-c+±4.4.7-4.el6.x86_64
gstreamer-plugins-base-devel-0.10.29-2.el6.x86_64
libogg-1.1.4-2.1.el6.x86_64
bzip2-devel-1.0.5-7.el6_0.x86_64
chkconfig-1.3.49.3-2.el6_4.1.x86_64
enca-1.13-1.el6.x86_64
gawk-3.1.7-10.el6.x86_64
libudev-devel-147-2.51.el6.x86_64
nss-softokn-3.14.3-9.el6.x86_64
acpid-1.0.10-2.1.el6.x86_64
libXres-1.0.6-2.el6.x86_64
libnl-1.1.4-2.el6.x86_64
elfutils-0.152-1.el6.x86_64
libcanberra-0.22-1.el6.centos.x86_64
sysvinit-tools-2.87-5.dsf.el6.x86_64
libwnck-2.28.0-3.el6.x86_64
coreutils-8.4-31.el6.x86_64
libsamplerate-devel-0.1.7-2.1.el6.x86_64
mysql-5.1.73-3.el6_5.x86_64
traceroute-2.0.14-2.el6.x86_64
libvorbis-devel-1.2.3-4.el6_2.1.x86_64
libxml2-2.7.6-14.el6.x86_64
unzip-6.0-1.el6.x86_64
grubby-7.0.15-5.el6.x86_64
acl-2.2.49-6.el6.x86_64
openldap-2.4.23-34.el6_5.1.x86_64
rpm-libs-4.8.0-37.el6.x86_64
upstart-0.6.5-13.el6_5.2.x86_64
clamav-0.98.1-1.el6.x86_64
perl-version-0.77-136.el6.x86_64
libpciaccess-0.13.1-2.el6.x86_64
gpg-pubkey-d0ff3d16-4e0fd442
ethtool-3.5-1.2.el6_5.x86_64
gpg-pubkey-11f63c51-3c7dc11d
centos-release-6-5.el6.centos.11.2.x86_64
zlib-1.2.3-29.el6.x86_64
yum-plugin-fastestmirror-1.1.30-17.el6_5.noarch
libselinux-2.0.94-5.3.el6_4.1.x86_64
util-linux-ng-2.17.2-12.14.el6.x86_64
pkgconfig-0.23-9.1.el6.x86_64
policycoreutils-2.0.83-19.39.el6.x86_64
perl-DBI-1.609-4.el6.x86_64
dracut-004-336.el6_5.2.noarch
perl-Compress-Raw-Zlib-2.021-136.el6.x86_64
postfix-2.6.6-6.el6_5.x86_64
perl-IO-Compress-Base-2.021-136.el6.x86_64
kernel-2.6.32-431.5.1.el6.x86_64
perl-IO-Zlib-1.09-136.el6.x86_64
awstats-7.0-3.el6.noarch
libselinux-devel-2.0.94-5.3.el6_4.1.x86_64

Howdy,

Okay, that MySQL version looks correct.

However, your previous comment makes me wonder… what happens if you run this command:

mysql -u root -p

And then enter your MySQL password – does it allow you into MySQL?

If so, what happens if you then run this command within the MySQL shell:

use mysql

Do you receive any errors trying to run “use mysql”?

-Eric

Howdy,

Okay, that MySQL version looks correct.

However, your previous comment makes me wonder… what happens if you run this command:

mysql -u root -p

And then enter your MySQL password – does it allow you into MySQL?

If so, what happens if you then run this command within the MySQL shell:

use mysql

Do you receive any errors trying to run “use mysql”?

-Eric

i am able to access my mysql by using my password with this command mysql -u root -p

but when i try this command “use mysql” again same message display “ERROR 1044 (42000): Access denied for user ‘root’@‘localhost’ to database 'mysql”

any idea ?

Thank You.

SQL is having trouble to localhost not also setup in the DNS as 127.0.0.1
I am using proxmox virtual environment at the container level and i had to setup it there…

Hi,
I have got the same problem as above:
The full MySQL error message was : DBI connect failed : Access denied for user ‘root’@‘localhost’ (using password: NO). When I type rpm -qa | grep mysql I get php-mysql-5.4.16-36.1.el7_2.1.x86_64, than after mysql -u root -p I get Enter password: and after I enter password I get ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

I have got centos-release-7-2.1511.el7.centos.2.10.x86_64. Any Idea?

Pawel

Even i got the same error,

DBI connect failed : Access denied for user ‘root’@‘localhost’ (using password: NO)

I am using Centos 6.8 Virtualmin 5.0.3 GPL.
I just changed the password of root going to Webmin ->System->Change Password (Change password for root and mysql)
after that i can able to login Webmin → Server → MySQL Database Server. Done.

Then go to Virtualmin → System settings ->Features and Plugins. Select the MySQL database and Save.
If you are getting a following error

Failed to save enabled features : Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add 127.0.0.1 to the list of DNS servers, or turn off the BIND feature on the module config page.

Just go to
Hostname and DNS Client or https://your_hostname:10000/net/list_dns.cgi and add 127.0.0.1 in your DNS servers. Save → Apply Configuration.

Now again go to Virtualmin → System settings ->Features and Plugins. Select the MySQL database and Save.

Just restart the webmin under webmin configuration and re-check the configuration under Virtualmin → System Settings.

This way it solved the dbi caonnect mysql problem for me, hope this will help newbie like me.