dav passwords

I haven’t used dav before, but recently I enabled it. I just clicked the checkbox to enable dav, and read the pop up that said to use email name and password. I went to log in from windows using my network places, and it didn’t ask for a password at all, it just let me right in. So I disabled it, and enabled it again, and now no password works. I checked the virtual host settings and then used htpasswd to create new passwords in dav.digest.passwd. I checked the permissions on dav.digest.passwd and changed them to 777 to eleminate that possibility. I encrypted the password using every method available according to htpasswd’s help files. I deleted the file and created a new one. I tried disabling and enabling dav again. I tried changing the users password from virtualmin. So finally I gave up and created a new server, enabled dav, and found that again i could access with no password. So I repeated the above steps again on the new server, to the same affect.

When I enable dav for the fist time, no password is required, when I disable, and then enable dav again, a password is requested, but none are accepted.

Has anyone here got dav working?

I’ve read through everything I can find and nothing seems to make it want to work.

Same problem here. It is not accepting any passwords. Any ports I need to open? Any config I need to tweak? Any help would be apreciated. I am using CentOS 5.2 and Virtualmin Pro 3.59. If you need any more info I can post it.

Edit: Ignore my post. I found the solution to my problem. I read at en.wikipedia.org that there were problems with Microsoft Windows and WebDAV. When I was trying to configure it at network places I was using this:


This wouldn’t work for me. Then I used this:


And Vouala! (I don’t know if I write it well :P)

Problem solved!

Post edited by: m4b, at: 2008/07/15 03:18<br><br>Post edited by: m4b, at: 2008/07/15 03:18

This doesn’t fix my problem. Adding the :80 makes it pop right up that its an invalid folder, whereas if i just use http:\domain.com\dav it does ask for the password, but still, never accepts it.

On another note, it isnt a password problem at all.

If i open www.domain.com/dav in a browser, it forces me to authenticate, and accepts it, then shows me some code.

Just incase this might help,
I found that you have to change the DAV Authentication Authentication type depending upon
what version of windows your connecting from
Basic for XP and Digest for the newer versions is what worked for me