Database password not updating correctly when enabling Virtual Server

I’ve noticed that when I disable a Virtual Server then re-enable it, the database connection always fails (for that particular Virtual Server).

The password seems to be the same in the mysql.user table (the authentication_string does not change) but the user will not be able to connect to the database until he/she changes the password.

The weird part is, going to “Virtualmin -> Edit databases -> Passwords -> Custom password” and setting the password as it was before does not help. You first need to put a different password and then input the same one as it was before (double update) in order for it to work.

Anyone else suffers from this issue?

No one else is suffering from this issue?