Database password not changing

I would like to change a password on a database I just uploaded. The password is ‘password’, so I tried changing via:
Virtualmin > select server > Edit Databases > Passwords > Change database password > MySQL database: Same as administration password > Save > config.php > $dbuser = '’; > $dbpasswd = ‘’;.
When the dbpasswd was the same as the VirtualServerAdministrationPassword, the database would not load. I changed the dbpasswd back to ‘password’ and the database loaded.

I also tried:
Virtualmin > Webmin > System > Change Passwords > VirtualServerName (I didn’t see the database’s name) > New password > New password (again) > Change.

Are you sure you have the latest version of Webmin (1.844) and Virtualmin (5.99). There were a number of changes made to support newer MySQL versions in recent releases. As far as i know, password changes are working correctly in the current version (but were not up until 1.84x).

I’m using

Operating system	CentOS Linux 7.3.1611
Webmin version	1.844 
Usermin version	1.711
Virtualmin version	5.99
Theme version	Authentic Theme 18.49-8
Time on system	Wednesday, June 21, 2017 5:53 PM
Kernel and CPU	Linux 3.10.0-514.21.1.el7.x86_64 on x86_64
Processor information	Common KVM processor, 1 cores
System uptime	1 days, 3 hours, 22 minutes
Running processes	110
CPU load averages	0.00 (1 min) 0.01 (5 mins) 0.05 (15 mins)
Real memory	1.75 GB total / 537.10 MB used
Virtual memory	1.95 GB total / 2.02 MB used
Local disk space	47.96 GB total / 45.24 GB free / 2.72 GB used
Package updates	All installed packages are up to date