Database backup failed : DBI connect failed : Access denied for user 'serveradmin'@'localhost' to database 'mysql'


When a Server’s admin tries to backup one of his Mysql database the following error appears:

Database backup failed : DBI connect failed : Access denied for user ‘serveradmin’@‘localhost’ to database ‘mysql’

I’m using Virtualmin Pro 4.10 with CentOS 6.5

I don’t know where I have to look. Any advice?



Hmm, were things working at one point, and recently stop? If so, do you know what may have changed recently?

Do you know if a non-default MySQL version was by chance installed? You can determine that by running this command:

rpm -qa | grep -i mysql


I don’t know when it stopped working as I’m always logged in as a System Admin and then it works correctly. I only had a complaint about it recently when a server admin tried to backup his MySQL database.

We haven’t installed any new MySQL version. This is the output of the command:

mysql-server-5.1.73-3.el6_5.x86_64 php-mysql-5.3.3-27.el6_5.1.x86_64 mysql-libs-5.1.73-3.el6_5.x86_64 mysql-5.1.73-3.el6_5.x86_64 perl-DBD-MySQL-4.013-3.el6.x86_64 mysql-devel-5.1.73-3.el6_5.x86_64 php54-php-mysqlnd-5.4.16-16.el6.centos.alt.x86_64


I have the same problem after recent update of packages. I think it’s something related to “database ‘mysql’” part of error message. It maybe an incorrect database selection bug.

Besides, I could backup with phpMyAdmin.

Hi, I reported the issue to developers. They determined the cause of this issue, it will be fixed in the next Webmin release (version 1.710).

I’m having the same issue - any way to backup the site ?
I need to move the site from one server to another.
is there a way around it - to create the backup ?


You should be able to back it up, if you perform the backup as the root user. Are you seeing problems with Scheduled Backups, or backups as the root user, not working?


I’ve updated the mysql root password both on server and in webmin. now it works…