Dashboard on 2.011 not working

OS type and version Debian 11
Webmin version 2.011


I’m on Virtualmin Pro on Debian 11 and just updated to Webmin 2.011 but after doing so I can’t access Dashboard. Everything else seem to work. Just seem, I haven’t tested everything, but when Clicking on Dashboard nothing happens. I’ve rebooted multiple times.

1 Like

Which browser? Does the problem exist in a different browser?

Are there any errors in the web developer console in your browser when you try to open the dashboard?

I’ve tried on Edge, Chrome and Firefox and the same problem with all 3 of them. The consol in Firefox does not say anything.

When clicking on Dashboard, the only thing that happends is that the red bar at the top keeps on moving.

Anyhow, the Edge consol says as per below picture

The fact it’s not able to load sysinfo.cgi tells us why it isn’t working, I think (that’s where the graphs come from), but why none of your browsers can load sysinfo.cgi is a mystery to me.

Is it possible you’re running out of memory? (I would think that would be intermittent though because the OOM killer almost certainly would not always kill the sysinfo process.)

Memory on the server I guess? If so, RAM or HD? I’ve manually deleted a huge cache and rebooted the server but no difference. In my providers, OVH, interface I can see that the RAM use is huge, over 95 % out of 8 GB. I don’t know what it is about.

I will go back to a mirror from last midnight so I reset to before the upgrade to 2.011. I’ll let you know the outcome.

“Memory” means RAM. HD is “storage”.

That’s not indicative of a problem. Linux caches disk accesses, so any active server will pretty quickly show 90+% memory usage. You can treat buffer/cache memory the same as “free”, as it is available for allocation without needing to swap.

See: https://www.linuxatemyram.com/

8GB should be plenty in the majority of cases.

I’ll try to reproduce it. I don’t think anyone else has reported it.

Thank you. I’ve just started a restore and we’ll see what happends. If all is fine with the old installation I will next evening again try to upgrade 2.011. I’ll let you know then what have happend. It’s late in Europe so I’ll go to bed now.

I just ran into the exact same issue and it tuned out that it was related to this : Error reading file /etc/network/interfaces: unexpected line 'source-directory /etc/network/interfaces.d'

While the dashboard is endlessly loading and sysinfo.cgi endlessly running, the the file /var/webmin/miniserv.error fills up very fast with the same repeated line: “file=/etc/network/interfaces line=source-directory /etc/network/interfaces.d”

1 Like

Aha ! So it is connected to what you wrote here: Error reading file /etc/network/interfaces: unexpected line ‘source-directory /etc/network/interfaces.d’ - Virtualmin - Virtualmin Community

Just for your information I’m back to 2.001 and it all work as it should, so it is clearly connected to the upgrade to 2.011.

Is this a Debian related issue?

I upgraded 5 boxes first thing this morning and Virtualmin Dashboard seems to be working tikety boo in (Chrome and Firefox) With the boxes in various timezones I have not looked at Webmin Dashboard (as usual) and not checked out the theme update. As everything seemed to work I’m OK. All boxes run Ubuntu 20.04 or 22.04 My only comment (trivial) is that the Stats History is taking longer to come to life (but that could simply be the data load (I have it set to 24hr). So CPU gets a hit while it loads.

Please see the thread Nico94 posted for updates.

Just popped over and nothing like that is happening on my Ubuntu boxes. My comment on the “Stats History” was very much “trivial” as it is only happening on initial Dashboard load. If it is a problem then it must be being cleared through once loaded.

Same problem with RHEL9 and Vmin Pro.

It all seems to be working except the dashboard, it reverts to the Webmin screen.

There is no such file or directory on RHEL9.

It’s entirely possible there is another issue that results in the dashboard failing to load that effects RHEL9, but it definitely can’t be the network issue that I believe explains this one. Please open a new topic.

We’ll need to see the miniserv.error log entries when you try to load the dashboard, the browser you’ve tried, and any errors in the web developer console in your browser. (None of my Rocky 8 or 9 systems are having problems, so I don’t have any way to reproduce your problem at the moment. So let’s discuss it in another topic.)

Sorry if that was misleading. I was following the original topic heading that the dashboard doesn’t display for me, it just shows the Webmin System Information screen.

There are no other problems that I can see, it’s just the display as per Topic and OP.

I’m having the same problem. The dashboard is not loading anymore. Debian 10. Is there a fix as of now?

Please see the other thread where this is being discussed: Error reading file /etc/network/interfaces: unexpected line 'source-directory /etc/network/interfaces.d'

I believe the problem is understood for Debian, and workarounds provided. But, if that thread doesn’t solve it for you, we need more information. As far as I know, it is the cause of the “no dashboard on Debian” problem.