Custom command doesn't receive parameter

I’ve created a bash-script, which need one parameter to run.
All works like a charm at CLI.

So I’ve created a “Custom Command” to be able to trigger this script from webmin-gui.
I did it like this:

As you see, the parameter “supplier” is required.
So if I do enter something in the Textfield and hit the Button to run it, the script noticed, that the parameter is missing.

So how do I have to add this parameter. Do I need to add something like $supplier to the “command” section in this “custom command”-setting to make this work?

Got it!

If you use parameters, you need to add those to the “Custom Command”.

In my example it would be:

~/scripts/  $supplier
1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.