Curl and GD- unable to get them installed and working!

Hi All,

I run a virtualmin server on xubantu.
I need to have Curl and GD working.

I’ve used the command shell to get/install Curl, it did it, and I restarted the server by turning it off and on again… , however curl does not seem to be working.

I’m unable to find a version of GD to install.- so Im very lost on that.

Please could you help?

Many thanks,


Are you asking about the PHP curl and GD libraries? Because I don’t think you’re making sense if you’re just talking about curl and GD. The PHP libraries are named php-curl and php-gd (or php7.2-curl, etc.) not curl (that’s the package the curl command comes in) or gd (there is no such package).

1 Like

Thanks Joe, I’m a bit new to Virtualmin and so appreciate your assistance!

The programme I’ve installed that is asking for them just asks for Curl and GD… it doesn’t put the PHP prefix in front!

However I managed to get PHP curl to load, but it does not seem to have installed according to the programme that asking for it.
I followed the same procedure for PHP GD- and the system could not find a file or process to download and install.
So I’m stuck!

Co you have any suggestions? I’d really appreciate some help, Im a convert from Cpanel and this is quite a steep learning curve!

Thank you if you can help, and I appreciate your getting involved if you cannot.



What is your server OS?

What program complain about missing dependencies?

I would make a guess and say that you need to install packages by name: php-curl and php-gd, however, these are installed by default.

What is the output of:

php -m

I solved his problem, I used this resource and installed the packages.

I’m glad you got it sorted, thanks for the update! But, you didn’t need to enable a third-party repository to solve it. Those packages are available for the PHP version included in your OS.

Also, you said you were using Xubuntu at the beginning of the thread and these are CentOS packages? That doesn’t make sense. :man_shrugging:

might be relevant,
got some php issues after upgrading debian, stretch -> buster . had to manually run :

phpenmod curl

etc, to get php modules activated…
really strange and that wasn’t the only problem with the php update… (7.0 -> 7.3)

Thanks for comming back to me Joe,
I could not find those packages in the Os. It may be that I simply do not recognise them as what they are . (I’m new to this!) Ill have a look in a while. Do you have a link to something on it?

the system is now working, so Ive proved that that a server can be run from hoe with a commercial broadband line and an alternative to Cpanel, so I’ll save myself £200 a month!

I made a bit of a mess in the machine and OS during the learning curve whist finding out if it was practical to run a server from home, so when I return in a fortnight I’ll strip out the machine and re install everything from scratch, without making all the mistakes again! (Perhaps some new ones!)

Thanks for your help!


Package names depend on your OS and version. Sometimes it’ll be php-gd and php-curl (or something like php73-gd). On CentOS there is a php-gd, but also some versioned ones like rh-php72-php-gd. The Curl module is php-pear-Net-Curl. Not sure if there are any versioned ones, so I guess a third party repo might be needed in that case.

1 Like

Thanks Joe,
Much appreciated!

I’m off to Spain for a weeks dancing holiday (I find the steps of the Tango just as bewildering as this lot!)

I’m into it again on my return.

Much appreciated!