Creating new virtual server deleted the contents of the /home/ directory?

Hi All,

I installed Virtualmin on a server with an existing Apache installation and existing virtual hosts.The existing virtual host files were located in /home/.

After installing virtualmin and creating a new virtual server within virtualmin, the /home directory only contains the following:

root@vm:/home# ls apache2-default astuteaccounting index.html webalizer wordpress

What went wrong and is there an easy way to recover the contents of the home directory?

I can restore from a backup but it means some data will be lost.


How did you go about installing Virtualmin? If you used the script, that’s only meant to be run on a freshly installed system (which the installer does mention when it runs :slight_smile:

The way it configures Apache, Postfix, and such can cause an existing setup to stop functioning properly.

That said – the installer never touches anything in /home (it has no need to delete anything anywhere on your system). Existing data should all be there, the only issue would be the various settings configured in /etc.

Is it possible that your data is within one of the directories you’re seeing in /home?


Can you show us the output of ls -l /home please? What contents did the home directory have before? Did you install the Wordpress script using Virtualmin after creating the vserver? Were there any errors? What did it say it would be using as the vserver owner’s home directory? Did you also delete vservers?

I’d have to agree with Eric and kinda doubt that Virtualmin would delete the /home contents upon installation or vserver creation.

Sorry - just noticed this.

The issue is solved - don’t have any explanation.

The /home directory was completely empty after the first installation attempt. Restored from backup.

We tried again two weeks later after making a copy of the home directory and moving the websites there. This time it did not clean out the /home directory and installed OK except for a missing serial key - this was my fault. Just figuring out how to rectify this now.