Creating new users creates an alias preventing login with roundcube

OS type and version Ubuntu 22.04.2
Webmin version 2.013
Virtualmin version 7.5
Apache 2.4.52
Postfix 3.6.4

I don’t know how I’ve fluffed up something in the templates and settings for server/user creation, but I have the following issue:

When creating a new user, I automatically have a new user alias that’s generated for the user. I’ve looked all over the settings and cannot find how to turn this feature off.

Currently, in Virtualmin, I have “System Settings->Server Templates->Default Settings->Mail for domain >> Mail forwarders for new users” set to ‘None’ along with the usual mail aliases for new domains at their defaults.
The “Mail alias mode for alias domains” is set to ‘Copy aliases from target’
Postfix settings remain untouched and are at default settings from a fresh installation of Virtualmin today.

In the Edit Mail Alias screen, I see the new user created as
Name: someusername
Alias Destinations: Address someusername\

Not only can I not prevent the alias from being created, but if it is not deleted, it prevents a user from logging into their email account in RoundCube.

I’ve tried all sorts of variations on the options and I’ve drawn a blank.

Some help would be appreciated.



I had fits with installing Mailman3 because the @ seems to block further recursions depending on where they are in the hierarchy of alias, virtual alias, transport. I have things working for the most point but I’m not comfortable with some of the aliases I’ve removed to get things to work further downstream. I see a section for transport maps that might help but haven’t looked into that yet. On my ‘todo’ list is some further understanding. No forum for Postfix. Mailing list.


After several more hours and constructing a new server template from blank, the problem still persists on a new user.

The alias is generated with a backslash prefixing the @ symbol. when in the template “Mail for domain” the user format is username@domain

If I set the username format to username.domain which was the Virtualmin default in days, way way back, then the alias is not generated and therefore no problem.

I suspect that an undocumented feature (AKA Bug) has ostensibly been introduced by placing a backslash after the username alias and before the ‘@’ symbol and I strongly suspect it’s nothing to do with anything I may have fluffed up as originally thought.

In fact there should not be an alias generated with the same name as the username - no wonder it’s causing havoc.

Can someone please confirm it’s either still my failure somewhere in the settings or it really is an undocumented feature?



I had the rouncube issue. Its fixed with this setting, not sure how you create that forward though, that weird.

1 Like

Thanks - that’s done the trick - no more aliases messing with my head.

1959 - we share something in common :slight_smile:

A good year :slight_smile: Yeah it had me stumped until one of the staff put me straight.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.