"create Virtual Server" creates an empty Master Zone. (Ubuntu)

OS type and version Ubuntu 20.04.6 LTS
Webmin version 2.021
Virtualmin version 7.7
Related packages BIND 9.16.1-Ubuntu

I’m using nginx with apache2 stopped.
I use chroot for bind9.


The following two errors occurred when executing “create Virtual Server” of virtualmin.

Adding new DNS zone ..
.. DNS domain failed! : bind8::flush_file_lines failed : Failed to open /var/bind9/chroot/tmp/.webmin/817062_706497_1_domain_setup.cgi for writing : No such file or directory

Performing other Apache configurations..
.. configuration failed : Failed to open /var/bind9/chroot/tmp/.webmin/817062_706497_1_domain_setup.cgi for writing : No such file or directory

There were no records in the ‘Edit Master Zone’ for ‘example.com’.

without creating example.com.hosts
example.com.hosts.lock was created.

I ran the command below.

cd /var/bind9/chroot
mkdir tmp
cd tmp
mkdir .webmin

Retrying ‘create Virtual Server’ gave no errors, but ‘Edit Master Zone’ for ‘example.com’ did not have any records.

“760423_725809_1_domain_setup.cgi” was created in “/var/bind9/chroot/tmp/.webmin”.

In “760423_725809_1_domain_setup.cgi” was written what should be written in “example.com.hosts”.

The last time I added a domain was in February. There were no problems at that time. I have been using Virtualmin for over 10 years and this is the first time I have encountered such an error. what should i fix?

(using Google translation)

1 Like

I also installed Virtualmin on Ubuntu 22.04 with the same result.

So when I downgraded with reference to the post below, the domain was successfully added and the zone record was created as well.

I have noticed something comparing ver 7.5-1 and ver 7.7.

Ver 7.7 “Create Virtual Server” does not have “Create server administrator” and “Create home directory” check boxes.

“Features and Plugins” settings are the same.

I would like to downgrade Virtualmin on all servers I own if there are no problems. Will downgrading the servers on which I am publishing websites cause any problems?

I would like to execute the following command.

apt install webmin-virtual-server=7.5.gpl-1
apt-mark hold webmin-virtual-server

Will this issue be fixed in the next version?

(I use Google Translate. Please forgive me if the text is not correct.)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.