CPU Load increases local disk space and virtual memory runs full


since some days i have a big problem, the CPU Load goes up and down between 26% and 65% continously while the Local Disk Space runs full with temporary data, also the virtual memory. It gets quicker and quicker full now 22 Minutes after Restart i am already at 46% Disk Space. What was weird is that i have restarted it yesterday before going to bed and awaited that all is full in the morning but all was normal. It must be temporary Data / Files because after a Restart all is back to normal.

Checked the Disk Usage of all Virtual Servers as the Disk Usage was at around 75% Disk Space but all was normal.

I have this setup since about a year and all packages, including Virtualmin and Webmin should be up to date. Last things changed was the Webmin update to 1.990, including Authentic Theme and i added a Virtual Server to Virtualmin as an E-Mailserver without Website.

Here is a Screenshot of the Dashboard with the full Disk

That is normal:

On running Processes List the Database Server is on top with CPU load but on 2nd to 5th is the Authentic Theme.

OS type and version ubuntu 20.04
Webmin version 1.990
Virtualmin version 6.17-3
Database Version MariaDB version 10.5.13

I have no Idea where else i have to search. Thank you in Advance for your Help.


Can’t help no ubuntu.
But from apache there where some versions updates with such kind of trouble, so also look in versions and updates for other software as apache for example.

And search the web for those versions and such troubles

You do have good full backups?

Did you try a full restart form the box allready?

You can try to install HTOP and look there on SSH , is easyer than Top and some more options

And try to see if some things are kind of same here.
Server 100% CPU, please help - Virtualmin - Virtualmin Community

You are right HTOP is easier and a lot more clearly. I have checked the Thread you mentioned first but for example is my cpu load never at 100% but my Local Disk Space gets full. Did restart now with shutdown -r now, will see if that helps something.

I have no full backup but of all important websites and Databases and local backups of my important E-Mails. So worst what can happen is re-install the server and upload that all.


Is MariaDB filling up space with logs?

var/log/mysql size is less than 100 KB.

No logs but it seems you are right, it is mariadb. I found this in the /tmp directory
Why do these temporary tables come up and how can i solve that problem?

Regards Chris

.MAD and .MAI files are created by “Aria”, a MySQL format like MyISAM but with some “extras”. The .MAD file contains data, the .MAI file contains indexes.

Most likely there was a a crash at some point and it going in a cycle of temp logs being created, with every reboot it will clear then build up again. So the question is what script/app you use or perhaps updated recently.

In your my.cnf file what is the default storage engine. Maybe it’s MyIsam. If anything but InnoDB, needs to be the latter. Make sure latest version of mariadb is installed. Existing tables can be converted to InnoDB.

Is there a way to open and read one of the mai or mad files? That would give me a hint. Last update was Nextcloud and before Webmin and the Authentic Theme.

To win a bit time and leave the Server up and running i purge the files now every 5 Minutes now with a cron job, so the Disk Space looks good now but Virtual Memory is almost full while Real Memory is at 12%.
I did now all Database related Maintenance Commands Nextclouds occ Console offers. I hope the Repair Command did the job. If not it must been the Webin or Authentic Theme Update.

Update: It looks like the Maintenance Work on the Nextcloud DB did change nothing.

They are temp files created by the database. Have no idea if you can read them or not. File is a temporary table that MariaDB wrote to disk because it was too large to keep in memory. Is your nextcloud using nginx reverse proxy? Did you make any changes to the default Nextcloud config. Did you amend my.cnf with max_join_size or any other changes to my.cnf? Set tmp_disk_table_size so that your file system does not exceed 90% full.

Check your disk usage in Shell.
I think the visual graphs may be misleading.
On your both screenshots - with the graph at 99% and 26% disk usage - the actual free disk space in the text field below, shows about ~ 500 MB free.
Maybe it’s just your disk is full. Check ,if there’s anything you don’t need and delete it to free up disk space.

I know already that the #sql-temptable… files (see screenshot above) fill up my disk and look further :slight_smile: because with the disk full image there are 500 MB and at the picture with 26% are 579 GB free space. I knew it from the Beginning that this must be temporary files because otherwise they wouldn’t have be gone after a restart.

1 Like

I didn’t amend the my.cnf because i cannot find the right one. /etc/mysql/my.cnf is just a symbolic link pointing to mariadb.cnf in the same folder. I tried to change the variables inside phpmyadmin but that is reverted after the mysql restart. Where does Webmin save the config?

I was away 9 hours away and forgot to enable the cron job. As i was back only the Virtual Memory was full but the Disk Space was normal. I did Reboot the Server and now the temptables coming back.

Neither Webmin nor Authentic theme put anything in a database.

Search the web :wink:

“nextcloud CPU Load increases local disk space and virtual memory runs full”

CPU load and extensive disk writes on the website nextcloud and others you can find.

DOCS and help there

and the github issues

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.