CPU and Memory usage from multiple journalctl processes

OS type and version Debian 12
Webmin version 2.105

Hey i’m running mail server on my vps, and I’m getting multiple same processes which eats up all the memory and cpu and server starts lagging. ClamAV is turned off, any ideas how to fix that? After killing or restarting server it solves it temporarily.


@nodas1, those are expected for collecting mail logs. However, @Jamie, perhaps we should limit it by using the --since switch, like --since "30 minutes ago"?

Odd that there are so many copies of collectinfo.pl running, since we have a check to prevent concurrent runs to avoid this kind of issue.

That said, I like the idea of using the --since flag. I’ll add that…

Fix is here : Don't read logs all the way back in time https://forum.virtualmin.com… · virtualmin/virtualmin-gpl@6f234e8 · GitHub

Thanks @Jamie, though, I think we should also consider adding --no-pager option, just in case.

Also, I don’t think we should always add --since '1 hour ago', because some programs, like bandwidth collection and others, may require more extensive results. I’d make it conditional for status collection only, where the since value depends on the status collection interval.

Good point … check out this update : Pass a sensible start time to journalctl when reading logs https://fo… · virtualmin/virtualmin-gpl@96af72e · GitHub

There will be update available in virtualmin or how to update from github?

You shouldn’t update from GitHub unless you are a developer and know exactly what you’re doing.

So how to fix it? I manually edited those files and updated according to @Jamie fix, but now I get other errors in my server…

evidently not.

So last good backup? Always a sensible place to start. The one you did take before “manually editing” files.

What errors are you getting now?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.