Could not work out exact PHP version when web host installed Webmin and I installed Virtualmin later

Am new to Webmin and virtualmin as a beginner setting up my new vps has not been easy for me. My host installed Webmin on my vps. I followed online tutorials and installed virtualmin.
At first it was showing me that my server is not ready for virtualmin to use.
I followed another online tutorial and created a server with my website domain name.
When I tried installing wordpress it now says

This script cannot be installed, as it requires PHP version 5.
This script cannot be installed, as this virtual server does not meet its requirements : Could not work out exact PHP version

Please help me solve this problem

What is the OS?

What are the outputs from php -v and php-cgi -v ?

Is the server in production use? If not, missed learning opportunity aside, reinstalling the OS from scratch, updating it, and reinstalling Virtualmin after the OS updates and a reboot may be the faster, easier solution.



Hi @Epiphany,

I do highly recommend you to install Webmin with Virtualmin on a fresh and minimal install of your favourite OS. If you are a beginner, I do recommend you Debian or Ubuntu maybe in this case.
If you fist install Webmin and later on Virtualmin, that’s not a good idea, the Virtualmin installer does everything for you actually, you just configure your hostname and run the install script as root.

1 Like

Thank you all for your reply. I installed php and everything in now working.
However I installed wordpress and it is showing me there has been a critical error on your website.

Yeah, hmmm… I think there is an error in your configuration… I recommend you reinstall your OS and just configure your hostname and after it, run the Virtualmin install script, as @RJM_Web_Design already mentioned, that might be the easiest solution, your server is still not in production use and just Wordpress is installed…

@Epiphany I have also faced similar kind of issues with Wordpress. As @RJM_Web_Design suggested you should try out a fresh install of Virtualmin on a fresh VPS. As you are new I suggest you to use Ubuntu as your OS.
You can follow the tutorial I am linking below to correclty install and configure Virtualmin on Ubuntu VPS.

How To Install Virtualmin on Ubuntu 18.04 (LAMP Stack)

If you run into any kind of issues during the installation and configuration feel free to post here.

1 Like

Or simply quote the error here. But thats not really a virtualmin issue.

Thanks everyone for the support, I really appreciate it.
I reinstalled my OS centos 7 and reinstalled Webmin using virtual admin and I worked like charm.
Thank you all for the help


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.