Could not update packages and mod_php module warning

SYSTEM INFORMATION
OS type and version Ubuntu Linux 18.04.6
Webmin version 1.991
Usermin version 1.840
Virtualmin version 7.0-4
Theme version 19.91.2
Package updates 64 package updates are available

Hello,

  1. I have available packages update on my server, but the update always failed whenever I tried to update it, please find the error below. What do I need to do to update this package?
  2. I also have mod_php module warning on my dashboard, should I disable it but I have about 10 website already running on the server and I don’t want them to break.

It would be greatly appreciated if you could help. Thanks.

Update error
dpkg: dependency problems prevent configuration of linux-modules-extra-4.15.0-177-generic:
linux-modules-extra-4.15.0-177-generic depends on linux-image-4.15.0-177-generic | linux-image-unsigned-4.15.0-177-generic; however:
Package linux-image-4.15.0-177-generic is not installed.
Package linux-image-unsigned-4.15.0-177-generic is not installed.

dpkg: error processing package linux-modules-extra-4.15.0-177-generic (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
linux-image-generic depends on linux-image-4.15.0-177-generic; however:
Package linux-image-4.15.0-177-generic is not installed.
linux-image-generic depends on linux-modules-extra-4.15.0-177-generic; however:
Package linux-modules-extra-4.15.0-177-generic is not configured yet.

dpkg: error processing package linux-image-generic (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-image-generic (= 4.15.0.177.166); however:
Package linux-image-generic is not configured yet.

dpkg: error processing package linux-generic (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-modules-extra-4.15.0-177-generic
linux-image-generic
linux-generic
Reading package lists…
Building dependency tree…
Reading state information…
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
linux-generic : Depends: linux-headers-generic (= 4.15.0.177.166) but 4.15.0.187.173 is to be installed
linux-headers-generic : Depends: linux-headers-4.15.0-187-generic but it is not going to be installed
linux-image-generic : Depends: linux-image-4.15.0-177-generic but it is not going to be installed
Recommends: thermald but it is not going to be installed
linux-modules-extra-4.15.0-177-generic : Depends: linux-image-4.15.0-177-generic but it is not going to be installed or
linux-image-unsigned-4.15.0-177-generic but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

The first thing I would do is update your Virtualmin/Webmin only. It’s out of date. Deselect all of the updates except for those.

Current versions are:
Webmin 1.994
Virtualmin 7.1-1

Also, are you using the LTS release of 18.04?

Install failed again as I tried to udate Virualmin/Webin even individually and YES I’m using LTS release of 18.04. Thanks for your help.

That’s odd. You haven’t changed or added any repositories lately, have you?

Have you tried updating the server via the terminal of the server and not through the Virtualmin panel?

@Gomez_Adams No

@Gomez_Adams thanks for your assistance, I have finally resolved it I ran this command on the terminal “apt --fix-broken install” and I was able to update all the available packages.

What should I do about the Warning on the dashboard of “Apache mod_php”, should I disable it because I’m afraid it could break my sites?

You’re the second person I’ve seen today with that issue. Maybe @Joe could better advise on this.

We have nothing to do with kernel updates. I have no advice beyond doing what the package manager suggests (I’m glad that worked).

The mod_php warning is our problem, and it probably is recommended to wait until the next Virtualmin virtual-server update to disable it, since we didn’t handle it correctly in the current release (clean up of the mod_php options in the Apache config didn’t happen automatically like it was supposed to…we vastly underestimated how many people had mod_php installed…we’ve been telling people not to install it for literally years).