Could not retrieve mirrorlist error?

Hey guys, I’m running CentOS 5 x64 on my vps and am currently trying to install virtualmin. While I’m running the script I get a few fatal errors and my installation stops.

“Could not retrieve mirrorlist 4&repo=os error was
[Errno 14] HTTP Error 500: Internal Server Error” seems to be the problem

Any suggestions?



That may just be a temporary error – I’m able to access the URL that’s giving you the 500 error.

If you try just running a “yum update”, does it work successfully now?


Hey, I’ve been getting this error since last night, so I’m almost sure its not temporary

I’ve tried running yum update / yum clean all and I get the same error message, as well as “Cannot find a valid baseurl for repo:base”

I tried changing /etc/resolve.conf to my dns information, but still no luck.

Any suggestions?

You’re not seeing a DNS error – the CentOS site you’re accessing is returning a 500 Internal Server error when you’re accessing it.

You may want to review the CentOS .repo file that’s setup on your server, as there may be some sort of issue with it.

That’s normally in /etc/yum.repos.d/CentOS-Base.repo.

If you don’t see any glaring errors in it, feel free to post the contents here.


Hey thanks for the fast replies.

This is what is in my CentOS-Base.repo file

Hmm, well, that all looks pretty normal.

Is there any chance you could put your actual error that you’re seeing in pastebin too? The error you posted above has some oddities in it, but I’m not sure which are just because Drupal mangled it, and which are because there’s something awry with how yum is accessing the repo :slight_smile:

Also, are you able to access this URL from your server? You can use a tool like wget or links… for example, you could try this:

wget ''

Also, what is the output of this command:

uname -a




After running:
wget ‘’ I get:

After putting in
uname -a i get:

The contents of my virtualmin-install.log are here:

Thanks again for the support :slight_smile:

Hrm, that all looks normal – outside of the errors you receive when trying to access the CentOS mirror site.

I’m really stuck as to what might be wrong, I’ve never seen anything like that before :-/

I take it you receive similar errors when running “yum update”, or when installing a package such as with “yum install strace”?