Correct network setting for EC2 AWS instance

Hello,

I’m new to Virtualmin and my IT Admin knowledge is limited (more fullstack dev than real Server admin).
I’m moving from ClearOs to Virtualmin and I still need to understand some basics.

My system is set and I have a first website (virtual server) running on an AWS EC2 instance with Debian10/MariaDB/Virtualmin. :hugs:

I added a second virtual server (and an alias for a third domain) but all point to the same first website.

I read about such issue (old thread) and check the troubleshooting page but it is not very helpful… and I’m scared to brick my server.

I understand one of the following setting is incorrect but I don’t know what to change (internal vs external). Help will be appreciated.

UPDATE
Darn… it worked only for one domain (test.mydomain.com, a brand new subdomain) but not for the existing domains I’m willing to move…

Summary

THIS DIDN"T WORK
Self reply as it may help someone else ! :wink:

I found this : https://github.com/webmin/webmin/issues/157#issuecomment-386915170

Virtualmin | System Settings | Virtualmin Configuration | Defaults for new domains | Address format for Apache virtual hosts
One can choose:

  • detect automatically (in my case it was a problem)
  • Always use * - this solved my problem:-)

So I deleted and recreated the virtual servers, problem solved.

On BIND DNS Server => Edit Records File (for this new .org domain) I see the following (information about the first website .net domain) - is it normal ?

Okayy… (feel a bit like talking to myself) :woozy_face:

I edited manually “/etc/apache2/sites-available/xxxx.org.conf”
I changed;
*:80
*:443
for
172.xx.xx.xx:80
172.xx.xx.xx:443
and it worked. I could access to the second website.

So
I recheck and set Virtualmin | System Settings | Virtualmin Configuration | Defaults for new domains | Address format for Apache virtual hosts

  • Always use IP

It is now working fine.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.