Confused about IP addresses and PTR and reverse PTR's

I tried reading documentation and searching the forums but now have a headache and need to get this solved.

I am running Virtualmin with many virtual hosts. The DNS and rDNS for my machine do not match as the Ip address that the server sends out from is fixed to a different Ip than the main IP of the server. Is there a way to make these match?

I have control over name servers and can also ask my ISP to change PTR records. To further complicate things, the virtual host that is having the issue with their emails being denied, due to unmatching DNS and rDNS records, has a dedicated IP address that is completely different from the main server’s IP. Is there a way to fix emails coming from this particular domain to it’s own IP and leave all the other hosts to the other sending ip? I am running Postfix version 2.3.3

What ever changes I make need to serve all the virtual hosts and the dedicated IP hosts as well.

Thank you for any insight you may have.

I’m not sure what exactly the problem is here. :slight_smile:

Just ask your ISP to set the PTR RR for your IP to the hostname you desire - i.e. the/a hostname that resolves to the respective IP address.

I think later versions of Postfix have an option to use a specific outgoing IP per domain. Eric certainly knows more about that, I never used it. What Linux distribution are you using?

There’s no such thing as “PTR and reverse PTR”. PTR are resource records that match an IP address to a hostname, as such they are always “reverse”.

Thanks for the response.

I’m running CentOS Linux 5.8.

Sorry if I wasn’t clearer. I’ll try to explain again. It’s possible that my understanding is flawed and compounding/confounding my efforts to solve the issue.

Postfix sends all mail out on ip and the PTR is set to But when you look up (DNS/a record) it shows ip

To further complicate things the specific client has a dedicated IP and I don’t know if that is even coming into play as a factor.

Craig’s list won’t allow emails saying that the DNS and rDNS do not match.

Yeah in this case you need to make sure that Postfix uses a specific outbound IP per domain. I haven’t used that feature yet, so can’t say how it works, but I read that it should be possible. You’ll need to google a bit about that. :slight_smile:

This will solve my problems me thinks.