Configuration could not be verified - is the username and password wrong? - Unable to set email on Thunderbird or Postbox

I am very new to Virtualmin. Previously I was using Webuzo which has a clean interface. But this Virtualmin has very very complex structure and organisations.
The only reason I am using Virtualmin is, I think my website runs fast on this than that of Webuzo.

I faced several problems after setup but I solved it by searching on the Internet. I am facing a problem which I searched on the Internet but didn’t found a solution.

The problem has I created an email account and later when I tried to access it using Thunderbird or Postbox email client I am getting this error: Configuration could not be verified - is the username and password wrong? on both the client. I thought my password may be incorrect so I changed my password from Virtualmin and later tried to access but still didn’t succeed.

Then I installed Roundcube but that gave me 500 error. So I installed Squirrel mail. I am able to login to my email account via Squirrel mail successfully using the same username and password but that same username and password are giving me this error on Thunderbird and Postbox - Configuration could not be verified - is the username and password wrong?

Can anyone help me with this?

I’m also facing the same issue. I’ve created a new mail account and I’m able to send and receive mails on it via usermin. Now I don’t know how to add this email to an external client like Outlook or Gmail. The Documentation ( doesn’t do any help with it and other articles are also not helpful.

I know the mail server for incoming and outgoing is as it says in the DNS records. Outlook, for instance also asks for Port, Encryption method and a check box that says Require Logon using Secure Password Authentication (SPA)

Where do I get these information?

@irfanalam123 I believe this would be the same information you would require for your problem too.

Anyone want to help out a couple of newbies here? :smiley:

This similar discussion covers one necessary fix to make SMTP authentication work:

The details you need in terms of port and encryption, I use the following on my Thunderbird client:

  • Port: 587 (this is the usual STARTTLS port; you can also use port 465, if 587 doesn’t work for some reason…it should also support encryption)
  • Connection security: STARTTLS
  • Authentication method: Normal password (or plain password; it gets encrypted via STARTTLS, so it’s not sending plaintext passwords)
  • Username: Must match exactly the “IMAP/POP3/FTP Login” name found on the Virtualmin users page (or, if you use user@domain.tld format users, it could also match user-domain.tld for clients and programs that won’t work with user@domain.tld names)

We do not use SPA; it’s a proprietary Microsoft protocol, and I don’t believe it is supported by any of our mail stack. But, if you’re using STARTTLS on port 587, everything will be encrypted by default. You may want to get a certificate for your mail hostname, and install it for Postfix and Doevcot (there’s buttons for that when you’re logged in as root and look at a domain’s certificate pages), so that mail clients won’t warn about a self-signed certificate (though if your mail client will remember the certificate after first visit, it’s probably just as secure as an LE certificate).

Note that the standard SMTP port (25) won’t work from home or even from the office for the vast majority of users, as that port is blocked by most last-mile providers to reduce spam.

Thanks Joe. I was able to send emails through SMTP. Although for reading mails through IMAP, I had to deselect SSL option (Port 110). Is that how its supposed to be? Is it safe?

Hey Joe. Sorry to wake up this thread again but I’m having more troubles. Using the above settings, I can add an email to Outlook or Gmail and can send mail through the address but I’m unable to send mail through PHP. I’m using a library called PHPMailer and I’m using the following settings:

$mail->SMTPDebug = 2;
$mail->Host = “”;
$mail->SMTPAuth = true;
$mail->SMTPSecure = ‘STARTTLS’;
$mail->Port = 587;
$mail->Username = “info.oviyastudios”;
$mail->Password = ‘PASSWORD’;

I’m getting an SMTP connect failed. Here is more info on that:

2018-04-05 15:35:47 SERVER -> CLIENT: 220 ESMTP Postfix (Ubuntu)
2018-04-05 15:35:47 CLIENT -> SERVER: EHLO
2018-04-05 15:35:47 SERVER -> CLIENT:
250-SIZE 10240000
250 DSN
2018-04-05 15:35:47 CLIENT -> SERVER: STARTTLS
2018-04-05 15:35:47 SERVER -> CLIENT: 220 2.0.0 Ready to start TLS
2018-04-05 15:35:47 SMTP Error: Could not connect to SMTP host.
2018-04-05 15:35:47 CLIENT -> SERVER: QUIT

Here is the FQDN I used while installing Virtualmin. Can you suggest a fix?