composing mail fails

Hi, when i try to compose mail in usermin I get this error inside the page:

HTTP/1.0 500 Perl execution failed Server: MiniServ/0.01 Date: Wed, 19 Oct 2011 21:41:43 GMT Content-type: text/html; Charset=iso-8859-1 Connection: close
Error - Perl execution failed

Undefined subroutine &gnupg::clean_language called at /usr/libexec/usermin/gnupg/ line 25.

I’m running centos latest with latest webmin/virtualmin installed with no errors elswhere that I know of.

Can someone please help?


That can happen if Usermin was updated, but not actually restarted.

You may want to try restarting Usermin with this command:

/etc/init.d/usermin restart

If that doesn’t help – what is the output of this command:

rpm -qa | grep usermin

i’m running centos 64bit. Also i’m in the process of updating a bunch of vmin packages.

Ok, i restarted usermin and it worked. is this a bug or something?


Well, normally Usermin is restarted during the update process. Something may have gone awry in your case… perhaps the process was stuck for some reason.


I also had the same problem and also on Centos (but 32 bit). Restarting it fixed it. Perhaps something is wrong with the Centos binaries where it is not restarted during the update process.