Command shell "Cannot establish connection to the host" error

SYSTEM INFORMATION
OS type and version Ubuntu 18
Webmin version 1.999

Please watch this short video to see what I am experiencing.

I can’t even change directory in the command shell. Sometimes it is giving “cannot establish connection to host” error, sometimes it doesn’t return any error but the directory won’t change. I’ve tried connecting with SSH and there is no problem.

This might be related to a bigger issue, I will describe it here:
My wordpress website had been running well for months. Recently it is reporting a lot of file permission error, I check folder owner/group and permission of the related folder, they are all normal 0755. I changed it to 0777, the related file permission error is gone. But there are still so many file permission errors that are related to other folders. One of the errors is like this:


I changed the folder permission to 0777 and although the file is uploaded to the folder it will still shows a simple ‘HTTP error’ message on this page.

Even if I can, I don’t want to change them all to 0777 just to solve the problem, I want to find out why all of a sudden this is acting up. Now the only thing I did before the problem occurs is dong some package update/upgrade: fortunately on my other server I haven’t done the upgrade, so I can get the screenshot as follows:

Another thing is this - I clicked the button and disabled it

Hello,

Command shell “Cannot establish connection to the host” error

Have you tried to force reload browser page by hitting Ctrl+Shift+R hotkey? But before that try force-restarting Webmin by running the following command in SSH:

/etc/webmin/restart-by-force-kill

I changed the folder permission to 0777 and although the file is uploaded to the folder it still shows a simple ‘HTTP error’ message.

Never do dat (set permissions to 777).

I check folder owner/group and permission of the related folder, they are all normal 0755. I changed it to 0777, the related file permission error is gone. But there are still so many file permission errors that are related to other folders.

Is suexec's user and group set correctly? Try changing PHP execution mode to FCGId or better PHP-FPM. If already set try to toggle it to regenerate configs.

Another thing is this - I clicked the button and disabled it

Great, also uninstall all php_mod related packages, like:

image

and

image

… and all other. Restart Apache manually.