Collectinfo.pl frequency

SYSTEM INFORMATION

Operating system Ubuntu Linux 16.04.7
Webmin version 1.973 Usermin version 1.823
Virtualmin version 6.16 Authentic theme version 19.73

I’m having some issues stopping the collectinfo.pl script from running every 5 minutes. I noticed that collectinfo.pl was taking a bit too much cpu for my liking so I wanted to reduce the frequency it ran to once per day instead of every 5 minutes. I went to virtualmin> system settings> virtualmin configuration> status collection > changed interval between status collection job runs to 1440 minutes. But the script still runs every 5 minutes. Is there something I need to do after changing the frequency? A specific cronjob I need to edit on the server? The webmin scheduled functions page doesn’t have any cronjobs running at a 5 minute interval so I’m not sure why it would be doing this. Thank you.

Hi,

When you save Virtualmin Configuration → Status Collection page, does the value collect_interval getting changed/updated in /etc/webmin/virtual-server/config file?

If so, re-running config check will update scheduled functions run time.

/etc/webmin/virtual-server/config/collect_interval does not change, it’s set as collect_interval=5 after changing the status collection time again, is it safe to just edit this file and change it from 5 to 1440?

Yes, a key collect_interval on /etc/webmin/virtual-server/config file can be change manually but re-check config must be run to have interval being updated.

Wait, if you go again to Virtualmin Configuration → Status Collection page and update time there by hitting save, later go back to that page again (or click back and hit Alt+R to refresh), does it contain the new value or old?

Refreshing the status collection page showed that collection interval was 1440 minutes, while the config file said it was 5 minutes. I changed the config file to 1440 then did Re-Check Configuration. After the Configuration check both the website and config file say 1440. But collectinfo.pl is still running every 5 minutes.

Then you’re looking into different collection. Have a look at Webmin ⇾ Webmin Configuration: Background Status Collection page.

Yes, thank you I figured it was something simple. Webmin background status collection is set to 5 minutes, when I change to 1440 and press save it just says “Error” , no further details on the page. /var/webmin/miniserv.error also only says “Error:” when trying to save. miniserv.log gives me:
[24/Nov/2021:13:36:57 -0400] “POST /webmin/change_status.cgi HTTP/1.1” 200 4616
Sorry I’m not sure what’s relevant to try and give more detail here.
Is there some way to change this through a configuration file rather than the web interface?

Collection interval must be an integer between 1 and 60, otherwise it would make more sense to simply disable it.

Yes, check /etc/webmin/system-status/config and /etc/webmin/webmincron/crons/*.cron files.

I’d recommend simply disabling status collection in this case.

Also, you could go to Webmin ⇾ Webmin Configuration: Webmin Scheduled Functions page, click on the cron job and set an interval with specific times.