Cloudmin Setup on Hetzner root servers

SYSTEM INFORMATION
OS type and version Ubuntu 22.04
Webmin version 2.001
Cloudmin version 9.6 Pro

I have tried installing Cloudmin Pro on Hetzner and can’t seem to get it right. A lot of guide say that networking is the tricky part on Hetzner root servers. Cloudmin installation script could never get it right. Even the Cloudmin network settings doesn’t seems to allow a working bridge configuration. So I gave up.

Instead, I setup the root server with KVM and I’m able to get network working. I’m able to create VMs on the root server and ping to them from outside.

But I really want to use Cloudmin. So I installed it on a different VPS. And tried to add my root server as a host system. It was a success. But still, I can’t create VMs on this host.

Creating virtual system with KVM ..
.. creation started with IP xx.xx.xx.xx.
Waiting for creation to complete ...................................
.. creation has completed successfully.

Fixing interface names in Grub configuration file ..
.. no Grub configuration file found!
Removing missing disks from fstab file ..
.. cleanup failed : Failed to read fstab file : No Linux partitions found in disk image /kvm/guest2.cloudmin.xxxxx.com.img
Expanding filesystem to 25 GiB ..
.. failed to find primary disk
Mounting new instance's filesystem ..
.. failed : No Linux partitions found in disk image /kvm/guest2.cloudmin.xxxxx.com.img
Adding DNS entry guest2.cloudmin.xxxxx.com. for IP address xx.xx.xx.xx ..
.. done
Starting up new KVM instance ..
.. failed to start : KVM instance was started, but could not be pinged after 60 seconds
Fetching current status ..
.. status successfully retrieved (Ping failed)

Re-fetching current status of host system cloud1.xxxx.com ..
.. status successfully retrieved (SSH)

Enabling system at host boot time ..
.. done

The VM never gets created on the host system. But Cloudmin claims it has been created and can’t ping.

I gave that up also and tried creating the VM on host itself with uvtool hoping I could add it to Cloudmin with Find KVM Instances option. This is the output I’m getting,

Finding running KVM processes ..
.. found 1 processes
Processing KVM command /usr/bin/qemu-system-x86_64 -name guest=guest1,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-2-guest1/master-key.aes -machine pc-q35-focal,accel=kvm,usb=off,dump-guest-core=off -cpu qemu64 -m 4096 -overcommit mem-lock=off -smp 2,sockets=2,cores=1,threads=1 -uuid b8610179-dbc3-432c-b653-d4f07460ee56 -no-user-config -nodefaults -chardev socket,id=charmonitor,fd=33,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device pcie-root-port,port=0x10,chassis=1,id=pci.1,bus=pcie.0,multifunction=on,addr=0x2 -device pcie-root-port,port=0x11,chassis=2,id=pci.2,bus=pcie.0,addr=0x2.0x1 -device pcie-root-port,port=0x12,chassis=3,id=pci.3,bus=pcie.0,addr=0x2.0x2 -device pcie-root-port,port=0x13,chassis=4,id=pci.4,bus=pcie.0,addr=0x2.0x3 -device pcie-root-port,port=0x14,chassis=5,id=pci.5,bus=pcie.0,addr=0x2.0x4 -device pcie-root-port,port=0x15,chassis=6,id=pci.6,bus=pcie.0,addr=0x2.0x5 -device pcie-root-port,port=0x16,chassis=7,id=pci.7,bus=pcie.0,addr=0x2.0x6 -device qemu-xhci,id=usb,bus=pci.2,addr=0x0 -device virtio-serial-pci,id=virtio-serial0,bus=pci.3,addr=0x0 -blockdev {"driver":"file","filename":"/var/lib/uvtool/libvirt/images/x-uvt-b64-Y29tLnVidW50dS5jbG91ZDptaW5pbWFsOjE5LjA0OmFtZDY0IDIwMjAwMTE1","node-name":"libvirt-3-storage","auto-read-only":true,"discard":"unmap"} -blockdev {"node-name":"libvirt-3-format","read-only":true,"driver":"qcow2","file":"libvirt-3-storage","backing":null} -blockdev {"driver":"file","filename":"/var/lib/uvtool/libvirt/images/guest1.qcow","node-name":"libvirt-2-storage","auto-read-only":true,"discard":"unmap"} -blockdev {"node-name":"libvirt-2-format","read-only":false,"driver":"qcow2","file":"libvirt-2-storage","backing":"libvirt-3-format"} -device virtio-blk-pci,scsi=off,bus=pci.4,addr=0x0,drive=libvirt-2-format,id=virtio-disk0,bootindex=1 -blockdev {"driver":"file","filename":"/var/lib/uvtool/libvirt/images/guest1-ds.qcow","node-name":"libvirt-1-storage","auto-read-only" ..
.. could not work out primary disk image

That didn’t work too. Next I tried Add KVM Instance under Add System. That too doesn’t work because there are options to select on under KVM process to manage. And Cloudmin gives an error on the next page about it.

I feel like I tried everything. But I doubt I did. What I’m hoping here is that someone can point me to right direction to get this working.

Thanks!

I’m having a similar problem on Debian Bullseye, except KVM and the VM’s were already in place, and I’m installing Cloudmin to manage them - but unable to run “Find KVM Instances” or “Add KVM Instance” manually, without the same errors. I also tried to create a new VM manually: the server was not pingable, it did not show up in my Virtual Machine Manager GUI, and though the disk images were created, I couldn’t SSH or console to them.