Cloudmin - KVM Wont boot from CD/ISO


We have recently deployed development servers to test out different control panel solutions so that we may move away from SolusVM.

I have been using Virtualmin for corporate websites for a long time now, but im at a loss with Cloudmin. It seems no matter what i do i cannot get this to work, nor are there any similar topics which makes me think im just missing a field or setting somewhere etc.

Every time i attempt to create an empty instance and mount a CD/DVD the VPS just will not boot from it. I have tried multiple settings and boot sequences but the VPS continues to try booting from HDD first. I have tried putting the file locally and creating a system image as described in the docs, both yield the same result. The Cloudmin templates work fine however.

Any thoughts are appreciated,

Thank you :slight_smile:

Hmmm…I’ve been able to do this without trouble in the recent past, like just a few weeks ago. All of the systems I’ve spun up lately have been custom installs from CD or DVD ISO images (not using the Cloudmin template systems), because I’ve been tinkering with other distros.

I’m not sure how to advise you to troubleshoot this one, since I haven’t seen it happen. Could you maybe post a screenshot of your options when firing up a new instance?

I have the exact same problem, tried many different times and ways. Same thing as you say. Did you ever figure out how to get it to work?

+1 Here! Had to delete a secondary DNS server because BTW of the problem here wich I narrowed down, believe it or not, to not having a swap partition. That’s why everything went so slowly didn’t ever think it could be related

So created a new one but the kvm VM hangs at “Booting from Hard Disk…” even if at the Change Boot Method > Boot device page it is selected CD or DVD drive. And each time I tried I did specify a CentOS 6.4 ISO file on the host system

Now… I can’t create enything but empty… VMs? That’s as uselesess as having some huge empty files just for eating your disk space :slight_smile:

Another one - why (is it supposed to work in this way?) if I enlarge a disk, the extended partiton on it is automatically resized and fills all the space? That’s why I deleted the VM in the first place, tried to make room for a swap space on it’s disk but couldn’t get it to work.

A second question - how do you pick up another iso for booting than the one selected at creation time, for an existent KVM VM from the Cloudmin GPL 6.9 interface?


Can anyone drop a word or two here pls? Those are serious issues, not being able to choose the boot method - any ideeas?

Hello community,

Seems there are a couple of people who are not able to create empty systems or are having issues with creation using a CD. I remember when I started using Cloudmin a couple of months or so ago, that I was able to boot from a CD and install a new empty system, but now I can’t.

I am not sure what has changed, but now I am not able to boot from these iso images that have been created into “CD” images via Cloudmin. If I select a boot method, the KVM instance will reboot, and doesn’t seem to see the disk. I used these directions to create the CD image to boot from on the host server:

Now, I want to use the new iso that is available as an installation image – when I goto “Create New System” > Empty System, I can select this new ISO image to install from and hit Save. Once I complete this, and when the virtual machine boots, it only boots to the empty hard disk file that doesn’t yet have an OS yet, since I am trying to boot from CD.

Is there something we are doing wrong, has the process for creating and using new ISO images to install from changed in the most recent virtualmin/webmin/cloudmin updates?

I contacted another user on this list, and they claim they are NOT able to create new empty KVM systems either on Centos6, but it’s seems that it works on Centos5.

I understand that Centos6 isn’t “officially supported” from the kvm-install-script docs, but now that Centos is at release 6.4, isn’t it about time now?

Cloudmin info:
Operating system CentOS Linux 6.4
Webmin version 1.620
Cloudmin version 6.9.kvm

Please let us know if we are all doing something wrong, or if this feature is broken in Centos 6 and we should stop wasting our time(since centos6 isn’t officially supported) - most folks building new systems today, are not using Centos5, as Centos6 is mature in it’s current release.

Thanks - I would appreciate any feedback.

Thought I was doing something wrong, but it is something that has to do only with cloudmin, and it seems this just doesn’t work. I mean you can’t do much else than… create a virtual machine and point it to the ISO… Problem exists also after creating it and trying to boot from the ISO (BTW still didn’t figured out how one can pick another ISO?). Can anyone drop a word here, why is this being ignored?

What I did was to detach all discs and re-attach them back again, taking pains to ensure that the ISO CD/DVD is listed as the first disk from the list.

After the CD/DVD has served its purpose, I detach it again.

At least, that works for me.