Cloud DNS: Route 53 - “Failed to save cloud DNS provider : No AWS region selected!”

OS type and version Ubuntu 22.04.4 LTS
Webmin version 2.105
Virtualmin version 7.10.0
Related packages DNS Provider

I am trying to integrate Cloud DNS AWS Route 53 to Virtualmin, I got the following error.
" Failed to save cloud DNS provider : No AWS region selected!"
Also, the option to select the zone from the droplist section is grayed out, and there is no " Default zone location" listed zone from the lists, as you can see from the screenshots below.
I have been searching in the the forums but could not find any hints similar to this problem, and I am not sure if I am missing something, would appreciate some guidance here


When you create do you see zones?

No Zone was created

In addition, when creating a new virtual server, I got the following subsequent error if I make Route 53 to “Create new DNS zones” as default in the “Server Template Default Settings”. I have been searching in the forums but could not find any hints similar to this problem, and I am unsure if I am missing something or if this is a bug. I would appreciate some guidance here.

“Adding new DNS zone hosted by Amazon Route 53 …
… failed : usage: To see help text, you can run: aws help aws help aws help usage: aws [options] [ …] [parameters] aws: error: argument operation: Invalid choice, valid choices are: activate-key-signing-key | associate-vpc-with-hosted-zone change-resource-record-sets | change-tags-for-resource create-health-check | create-hosted-zone create-key-signing-key | create-query-logging-config create-reusable-delegation-set | create-traffic-policy create-traffic-policy-instance | create-traffic-policy-version create-vpc-association-authorization | deactivate-key-signing-key delete-health-check | delete-hosted-zone delete-key-signing-key | delete-query-logging-config delete-reusable-delegation-set | delete-traffic-policy delete-traffic-policy-instance | delete-vpc-association-authorization disable-hosted-zone-dnssec | disassociate-vpc-from-hosted-zone enable-hosted-zone-dnssec | get-account-limit get-change | get-checker-ip-ranges get-dnssec | get-geo-location get-health-check | get-health-check-count get-health-check-last-failure-reason | get-health-check-status get-hosted-zone | get-hosted-zone-count get-hosted-zone-limit | get-query-logging-config get-reusable-delegation-set | get-reusable-delegation-set-limit get-traffic-policy | get-traffic-policy-instance get-traffic-policy-instance-count | list-geo-locations list-health-checks | list-hosted-zones list-hosted-zones-by-name | list-hosted-zones-by-vpc list-query-logging-configs | list-resource-record-sets list-reusable-delegation-sets | list-tags-for-resource list-tags-for-resources | list-traffic-policies list-traffic-policy-instances | list-traffic-policy-instances-by-hosted-zone list-traffic-policy-instances-by-policy | list-traffic-policy-versions list-vpc-association-authorizations | test-dns-answer update-health-check | update-hosted-zone-comment update-traffic-policy-comment | update-traffic-policy-instance wait | help”

Maybe one issue at a time, have you fixed your original post.

Still having the the issue, it has not been fixed yet

Anyone else with the same OS seeing this issue???
The default zone location is populated on my OS Rocky9.

Thanks, Stefan1959, for the help
I also opened a separate case with Virtualmin’s staff, and I finally heard back from Virtualmin staff, They confirmed this was a bug and they are looking into fixing it in the next Virtualmin release,

However, “the short-term workaround till then is to first add your AWS account on the S3 Accounts page under Backup and Restore”.

So, I did the short-term workaround, and it worked. I could add an s3 account successfully, and both s3 and route53 are working now. After adding an s3 account, I was able to see the Default zone location listed in Route 53. Am able to see the zone created in route53 now


Right, I have a S3 so that why it showed. Good catch.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.