Clean RHEL 9.3, install VMin 7.10 doesn't enable quotas

OS type and version RHEL 9.3
Webmin version 2.101
Virtualmin version 7.8.2

Fresh install of RHEL 9.3 minimal. Filesystem is xfs.
Fresh install of Vmin using installer 7.1.0 from the Downloads page.
Take snapshot.

Quotas aren’t being enabled.

I have tried editing fstab then “mount -o remount /” but get the message:

“mount: (hint) your fstab has been modified, but systemd still uses
the old version; use ‘systemctl daemon-reload’ to reload.”

I run “systemctl daemon-reload” then rerun “mount -o remount /” and there is no error message, but running “mount |grep quota” shows

/dev/mapper/rhel_hostsystem-root on / type xfs (rw,relatime,attr2,inode64,logbufs=8,logbsize=32k,noquota)

Restore snapshot.

Go Webmin, System, Disk and Network Filesystems, both user and group quotas are On for /(Root filesystem)

Go System, Disk Quotas, shows User and group quotas inactive.

I have tried a couple of other things eg copying the fstab line from another system - each time using the restored snapshot, but nothing works for me.

Any help appreciated.

I think its because of the drivers. In some cases while using ubuntu we have to install

apt install linux-image-extra-virtual

to make Quotas work.

I dont know about RHEL maybe you should do same research on internet. Maybe you also need some driver like that.

Also make sure that necessory modules are loaded like modprobe quota_v2

run command

sudo modprobe quota_v2

to load the module and dont forget to enable it on boot time by editing the config file.

create a new file in /etc/modules-load.d/ by running this command

sudo nano /etc/modules-load.d/quota_v2.conf

now add


in that file. This will enabled that module in boot time. Now Quota should work perfectly.

Do let me know by reply if it worked. I hope it helps.

Thanks for the reply. I did spend some time searching and trying things before asking here.

Your suggestion “sudo modprobe quota_v2” didn’t appear to help.

I might have to try replicating my production server using the Vmin installer 7.0.2, as it appears there have been some issues with the recent versions.

I think this might be the key but I am not sure what it is pointing to.

“mount: (hint) your fstab has been modified, but systemd still uses
the old version; use ‘systemctl daemon-reload’ to reload.”

The problem is with the new RHEL 3 release.

I installed minimal 9.2 and ran the installer -x (no updates) and it worked fine. I then updated it and still worked fine.

So, with 9.3 without any OS updates, the quota, usrquota and grpquota are added to fstab, but it still fails to activate quotas. Running “mount |grep quota” shows noquota.

Also, starting with 9.2 and updating the OS before installing Vmin still stops quotas

So don’t worry about RHEL and wait and see if the same problem happens with Rocky and Almalinux when they release 9.3?

I tried clean install with RHEL 9.3 and it seems at first glance to work just as it always did with XFS, i.e. requiring to reboot the system to enable quotas:

However, quotas aren’t enabled after reboot. We will have a closer look! Thanks for the heads up!

1 Like

I have taken a deeper look into it and it isn’t clear why xfs_quota -x -c 'report' returns nothing even though quotas are clearly enabled in /etc/fstab and /etc/default/grub. Also running xfs_quota -x -c 'limit bsoft=500m bhard=550m user1' / returns:

xfs_quota: cannot set limits: Function not implemented

It is confusing because XFS module is (always) loaded, e.g.:

[root@rhel9 ~]# lsmod | grep xfs
xfs                  2048000  2
libcrc32c              16384  4 nf_conntrack,nf_nat,nf_tables,xfs
[root@rhel9 ~]# 

I hope @Jamie or @Joe have any ideas. For me right now it looks like a bug in RHEL 9.3.

Did you reboot after? AFAIK, XFS requires the filesystem be unmounted and remounted to enable quotas, which can only easily happen on a reboot if the filesystem is in use. The -o remount option or whatever doesn’t work for enabling quotas on XFS, I don’t think.

Of course I rebooted.

Yeah a reboot is necessary on XFS filesystems to enable quotas.

I have searched a fair bit for anything related to RHEL 9.3 and quotas and found nothing.
Can you guys log a fault report on Bugzilla?

Sadly, I see the same issue in AlmaLinux 9.3 as well! It isn’t clear why quotas are not getting enabled even after reboot.

The main difference between clean Alma 9.3 install (where quotas don’t work), and previous installs (where quotas work) is that LVM is being used by default in the latest 9.3.

To be clear, the same AlmaLinux 9.3 clean install using ext4 + LVM works just fine.

Are you able to enable quotas on XFS manually? If we know what works, we can update Webmin to do the right thing…

Are you able to enable quotas on XFS manually?

No, quotas with XFS in LVM simply don’t work. I don’t know what’s wrong! Presumably this is an upstream bug, maybe?

Yes, I’d be happy too to update Webmin to do the right thing. Sadly, there is nothing I could find neither in release notes nor in documentation about any changes and why it may not work. I’m afraid to spend that much time with it, as suspect it could happen to be the bug in upstream libraries.

1 Like

What does your /etc/default/grub file look like? It seems like the options to enable quotas are different to what’s in /etc/fstab , as mentioned in Quotas do not work with AlmaLinux and XFS file system (Solved) | DirectAdmin Forums

It looks like this:

GRUB_CMDLINE_LINUX="crashkernel=1G-4G:192M,4G-64G:256M,64G-:512M resume=/dev/mapper/almalinux_alma9--gpl-swap rootflags=uquota,gquota"

Also, /etc/fstab as well contains correct values to my perspective:

/dev/mapper/almalinux_alma9--gpl-root   /       xfs     rw,attr2,logbsize=32k,usrquota,quota,logbufs=8,inode64,grpquota,relatime        0       0

We’re enabling XFS quotas here, and it has worked fine for XFS for years. But new XFS + LVM is failing to work.

Hmm … I think this is something you could follow up with on the Alma forums, and let me know what you find out.

Keep in mind that I reported that if you start with 9.2, enable quotas and then update to 9.3, the quotas keep working.

Perhaps test if you can them remove quotas and put them back again?

9.2 updated to 9.2 before adding quotas is the same as just 9.3 - doesn’t work.

As you install 9.2, does LVM gets enabled?