Clean install virtualmin on same server

OS type and version CentOS Linux 7.9.2009
Webmin version 2.013
Virtualmin version 1.860
Related packages SUGGESTED


Is there any way to clean install of webmin/virtualmin?
I have made a mistake to install it on local network for test, it was installed on ip and now I can’t see it on internet, I can access it only on real ip, but on domain name doesn’t work.(dns has been changed)

on network interfaces - active now it looks like:
[em1] Ethernet 1000Mb/s fe80::efa6:afa7:1a37:e491 Up
[em1:0]Ethernet (Virtual) Up

I tried to change em1:0 to real ip but it doesn’t work…

It’s there any way to run configuration again, or network configuration?

Even if I try to create new server I get: Failed to work out externally visible IP address


Virtualmin does not “install on” an IP. It would be extremely silly to reinstall just because you changed the IP of the system.

You can change IPs of virtual hosts very easily, there’s a page for it in Addresses and Networking->Change IP Addresses.

Of course, you should also check to be sure Virtualmin is using the IP you want. Run Re-check configuration, and if it’s not the right IP, you’ll wan to go to Virtualmin Configuration->Networking Settings to give it some clues about what you want.

Yes, you have right, I already tried this, with IP Change but domain still doesn’t want to load virtualmin interface …

on domain I already create dns, ns1 and ns2 with server ip, but I still get error to load page…

I can access server from real ip, dns service it’s started… everything seems to be ok …
I was thinking is more easier to try clean install and to install it from real IP address and not local IP address … because on network interface I still have local ip’s.


The name servers you set up aren’t propagating. That’s the problem.

It’s either that or you haven’t pointed your domains from your registrar to your nameservers. If you have in fact done that, the easiest way to fix it is to use Cloudflare for your DNS.

The fellow in the thread below had the same issue you do. He swore he had his nameservers and DNS set up properly. Turns out, he didn’t.

I told him to use Cloudflare and it’d be fixed in 10 minutes. He did eventually and it was.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.