ClamAV update in Virtualmin

Hi there,

Yes another post from me. But this time I am trying to make it informative so that others might be able to try it as well because I couldn’t find anything that had complete instructions anywhere, just little bits here and there so I posted it all here.

Well I finally decided to try and get a new ClamAV on my new server since the old ClamAV is really old and I want a new one and so does everyone else. Why isn’t there a new one? I don’t know but it seems like a really important thing to me and after ages of warnings I got sick of it and tried to figure it out.

I knew it was going to be easier than it seemed but haven’t really gotten into it until now. It must definitely be easier to do what I did than packaging it by the sounds of it which would explain the lack of updates. However, I think it is still necessary and I don’t understand why neither CentOS, Virtualmin nor Virtualmin Bleeding Edge repos have an updated version. Maybe they are just having troubles packaging it?

So anyway, I discovered I can use RPMForge

But first I had to run yum remove clamav* so it would be able to install the new one without conflicts.

Then I discovered I can include and exclude packages in the repo files.

I edited /etc/yum.repos.d/rpmforge.repo and added this line:

includepkgs=clamav clamav-devel clamd clamav-db

Then I ran yum install clamav clamav-devel clamd clamav-db

It installed successfully!

I’m sure I must be missing something because there was some other files that uninstalled that didn’t reinstall such as one that was clamav-fileserver or something like that which uninstalled and some others I think too. But maybe thats just from the old version and the new version is simply different.

I even did a complete scan of the entire system with clamscan and found no infections. Good to know the old version wasn’t missing anything on the server at least but I was unable to update new definitions anymore it seems.

I added some exclude=clamav* lines to the other repo files for good measure. I don’t know if thats the way to do it or not but it seems to work ok.

However I am not so sure the includepkgs works properly through Virtualmin because upon logging in I see 35 updates to system packages are available. Use the Virtualmin Package Updates module to install them selectively. and 10 updates to Virtualmin packages are available. Use the Virtualmin Package Updates module to install them selectively.

So something fishy is going on there. Any ideas what it could be?

I can even do yum update and get nothing:

[root@ns1 yum.repos.d]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • addons:
  • base:
  • extras:
  • rpmforge:
  • updates:
    virtualmin | 951 B 00:00
    virtualmin-bleed | 951 B 00:00
    virtualmin-universal | 951 B 00:00
    Reducing Red Hat Enterprise 5 - - dag to included packages only
    Excluding Packages from Red Hat Enterprise 5 - i386 - Virtualmin
    Excluding Packages from Red Hat Enterprise 5 - i386 - Virtualmin Bleeding Edge
    Excluding Packages from Virtualmin Distribution Neutral
    Setting up Update Process
    No Packages marked for Update

I don’t usually worry about viruses much because I run Linux on my laptop anyway but its good to scan emails for everyone on my server and run a cron to scan the /home folder each day where people might upload files.

Perhaps someone should make a double Bleeding edge Bleeding edge repo and stick a new ClamAV and a new everything else in there like the newest versions of PHP, Apache, MySQL, maybe even a Kernel, etc.? Now that would be true bleeding edge. It is obviously a lot of work and I don’t expect that but one can dream. I don’t even like building things like PHP or Apache from source for fear I will mess something up. I can’t imagine packaging something thats a nightmare to package because I have no idea what that involves yet. Though I hear OpenSuse is supposed to be able to package things for every other distro somehow so maybe it would make it easier since I have that on here.


It is weird… I added Atomic Rocket Turtle repos to my server, and disabled the virtualmin and *-bleed.repos until this is resolved. Now my clam is running .96 and if I enable virtualmin repos they try to update it to an older version, .94

Blah… Everything I need is working in virtualmin right now so I’ll just leave those repos disabled.

I’m not sure why all that’s the case, since 0.95 is in the Virtualmin repo (and shouldn’t be affected by the ClamAV EOL issue).

However, you should be able to use the excludepkgs tag in the .repo file to tell yum not to pull clamav related updates from the Virtualmin if you’re seeing problems… that would allow you to continue using the Virtualmin repo, but without it attempting to touch clam.

I’ll pass the info onto Joe and Jamie that you guys are having some trouble with all that.


An maybe thats why, I did not use any excludepkgs tag. I used only exclude=clamav* and as you can see from yum update, it worked with yum but not Virtualmin.

I got the info from running the command: man yum.conf

Tons of options for that thing.

Well I just checked in Virtualmin it seems to be gone from Virtualmin now, I don’t think I changed anything so maybe it was cached for a long time. I just installed it on this new system and probably have to configure a bunch of things still. Maybe on the old system I had turned the cache off at some point.