clamav: change from standalone to server

I’m trying to change from standalone to server and I get the following error: Can’t parse clamd configuration file /etc/clamd.conf. thing is my conf is in /usr/local/etc/clamd.conf.

how do I get virtualmin to find the conf file?



Hrm, I don’t see a way to get Virtualmin to look in another place (which doesn’t mean you can’t, but I’m not sure how to do it :slight_smile:

You can, however, create a link from where Virtualmin is looking to your actual config, which will in effect fix your issue.

To do that, you can type:

ln -s /usr/local/etc/clamd.conf /etc/clamd.conf

Now, before you do that, I’d make sure you don’t already have a file named “/etc/clamd.conf”.


I added the sym link (after double checking the file did not exist) and now I get the following error:

The selected virus scanning command does not work :

ERROR: Command rejected by clamd (wrong clamd version?)

Anyways, I then started thinking do I even have the server installed, so checked to see if (and I’m assuming this is correct) clamav-server was there - which it wasnt.

So I installed it.

but i still get the same error message as above.

Any ideas?



Well, it sounds like your Clam install is in /usr/local, which seems a little unusual.

Now, I figured Virtualmin could be configured to make use of that, though I don’t see where that can be done.

But if you didn’t purposefully install Clam into /usr/local, I guess I’d like to explore that a bit –

How did you install Virtualmin? Did you use the

And do you know what ClamAV packages you have installed?


I did use the script, but decided to use my own install of clamav as opposed to the virtualmin one due to slow turnarounds in versions. When this was improved, I decided to go back to using the virtualmin repo, but this has obviously caused problems.

I’m using the clamav package from the virtualmin repo and it set itself up as follows:

Daemon init script path: /usr/local/sbin/clamd
Configuration file path: /usr/local/etc/clamd.conf
Main virus signatures database path: /var/lib/clamav/main.cld
Daily virus signatures database path: /var/lib/clamav/daily.cld

I’m happy to remove and start again, but this is how the package was installed via yum, so I’m a little lost as to where to go from here.



For anyone else coming to this thread – we discussed all this in IRC a bit.

What he’s going to do is try removing all remnants of Clam, and start over, pulling in the Virtualmin Clam version via yum, and then move it over to the clamd mode, which will lessen the load on the server.


Phew! I reinstalled everything.

I used Virtualmin to install the packages, and so installed the following (note some are dependencies):

clamav 0.95.2-1.vm.el5
clamav-data 0.95.2-1.vm.el5
clamav-filesystem 0.95.2-1.vm.el5
clamav-lib 0.95.2-1.vm.el5scanner
clamav-server 0.95.2-1.vm.el5
clamav-server-sysv 0.95.2-1.vm.el5
clamav-update 0.95.2-1.vm.el5

Then went to Virtualmin > Email Messages > Spam and Virus Scanning.
Then clicked ‘Enable ClamAV server’. Virtualmin did it’s stuff.
Selected ‘Server scanner (clamdscan)’.
Clicked Apply.

All set!

3945 nobody 18 0 105m 71m 1012 S 0.0 7.1 0:02.67 clamd.virtualmi

Thanks andreychek. Turned a stressful day into a successful one :slight_smile: