Chmod needed in script

in reference to forum post How to fix Webmin repo: NO_PUBKEY 2D223B918916F2A2 - #5 by Juso

I continue having issues with NO_PUBKEY errors on Ubuntu 22.04 using the latest script. I discovered in my case the error is happening because of file permissions on /usr/share/keyrings/ubuntu-webmin-developers.gpg

Please consider adding the following after installing the webmin key in the script:
chmod 644 “/usr/share/keyrings/$repoid_debian_like-$webmin_key_suffix.gpg”

Thank you for the suggestion.

Typically, the default permissions for a newly created file should be 0644, assuming the umask is set to 0022, which, by the way, is the default across all the systems we support.

To check the current umask setting, simply type umask in the terminal and press Enter. This command will display the current umask value, which determines the default permissions for newly created files and directories. The output will be a numerical value representing the permission bits that are masked out.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.