Checking Configuration wont read Logrotate version

When I run Checking Configuration it does not see Logrotate version correctly, system says it has version 3.7 on, but as you can see below I have posted results from the check and says version must be above 3.6

Checking Configuration

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Mail server Postfix is installed and configured.

Apache is installed.

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

The Logrotate program appears to be version , but Virtualmin requires version 3.6 or above in order to support multiple log files in the same section.

… your system is not ready for use by Virtualmin.

Please help

Are you sure you’re running the latest version of Webmin? A bug just like this was fixed a couple of months ago.

If so, then it’s still misdetecting the version in some circumstances. You’ll want to file a bug…but you’ll need to provide a bit more information in order for it to get fixed. Jamie will need to know the OS and version, as well as the output of “logrotate -v”

Great to get such a quick responce.

Its running Webmin 1.410 on CentOS Linux 5, not sure what version of virtualmin is on the server.

I asked the system to update all installed components that had newer versions and have had the problem ever since.

It was a clean installation, had added nothing to the system.

Hmm…That’s weird. Everybody’s running CentOS 5 (it’s by far the most popular OS for Virtualmin, even on our own servers), and we’re not seeing this issue.

What’s the output of “logrotate -v” on your system?

Iam new at this,
it is running on a VPS hosted for me.

Their techie said he has no idea why its doing it.

I can email you my login if it will help you to see for your self.

Or you could just run the command (login on the command line, or use the Command Shell in Webmin, if you’re nervous about ssh):

logrotate -v

And tell us what it says. This one aint rocket surgery. :wink:

Here is the responce

> logrotate -v
logrotate 3.7.4 - Copyright © 1995-2001 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License

Usage: logrotate [-dfv?] [-d|–debug] [-f|–force] [-m|–mail command]
[-s|–state statefile] [-v|–verbose] [-?|–help] [–usage]
[OPTION…] <configfile>

Any News yet please I really need to get this server up and running.

I have 30 domains I need to setup.

This sounds like a Virtualmin bug, but I don’t recall seeing it before.

I could login to your system myself to take a look - you can send me login details at

Jamie email has been sent

Odd, I haven’t received it yet. What address did you send it from?

Have you had a chance to check yet.

All I am trying to do for now is setup as the main domain
with and as my 2 DNS addresses.

Then I need to setup 30 or so domains as virtual servers.

I have now had this VPS for almost 2 weeks and not been able to do a thing yet.

Its prepaid for 3 months so I have a time limit.

Thanx again for all the help so far.

Looking at it now … your email with the password got put into my spam folder, so I didn’t notice it at first.

Ok, I see the problem - your system only has 64M of RAM. That is not enough for Virtualmin to do anything, and will cause random failures due to commands it runs dieing due to lack of RAM.

I strongly suggest upgrading your VPS to at least 256M, preferably 512M. I’m certainly that this will resolve the problem.

Also, I noticed that your Virtualmin version is quite old. Once you have more RAM, you can update with the command :

yum install wbm-virtual-server wbm-virtual-server-theme webmin usermin

no problem let me know how it goes.

I have asked them to otherwise do a new installation of the VPS from scratch.

Then I wont do the all upgrades.

Thanx I will send then here to read the posts
and then see what happens.

Thanx for all the help.

I know that Virtualmin can run with (far) fewer services in 96MB, but 64MB is too tight for pretty much anything except very basic Apache (and no management tools). You’ll need plenty of swap space, in either case (and time to wait on things to swap in and out while working).

There is a guide for running Virtualmin on low memory systems, and it’s possible to get a pretty full-featured system except AV/spam scanning (which are hugely resource intensive) into 128MB.,virtualmin_on_low_memory_systems/

Thanx for the info.

They are going to bump the ram to 128 to see if that helps.

I am also going To disable preloading of Webmin libraries

for now once the server has rebooted.

Yes, turning off preloading will help a lot.
Also, go for 256M if you can - even 128M may be a little to small, depending on what services you are running.