Check for curl ?


How do I check to find out if my php version
is supporting CURL and GD ?

Do I need to look for libraries or modules ?
Is it shown in the php.ini file ?

Thanks<br><br>Post edited by: Davvit, at: 2008/12/14 11:30

You can type this on the command line:

php -i | grep curl
php -i | grep GD

On my system that has both, I see this:

$ php -i|grep curl
additional .ini files parsed => /etc/php5/cli/conf.d/curl.ini,
cURL Information => libcurl/7.18.0 OpenSSL/0.9.8g zlib/ libidn/1.1

$ php -i | grep GD
GD Support => enabled
GD Version => 2.0 or higher

If you don’t have it, there’s PHP packages named something like php-curl or php5-curl, depending on which distro you have – you’d simply have to install that and the similarly named php-gd/php5-gd package.

You can type this on the command line:

How do I pull up "the command line"

( I am using VirtualMin Pro )
and Webmin of course.

I’m referring to the command line you’d get when logging into your server over SSH.

Well I dont think I ever do that :frowning:

I just use the menu system for Virtualmin or Webmin.

Do I use this (the last one on the list)

OR do I access it some other way ?


the easiest thing is to download putty and learn some basic command line stuff.
else you can go under webmin to Others and use the SHH/Telnet Login module.

You could also run this command in the Others:Command Shell module (which doesn’t allow interactive sessions, but this particular command requires no interaction).

I got these outputs:

> php -i | grep curl
Configure Command => ‘./configure’ ‘–build=i686-redhat-linux-gnu’ ‘–host=i686-redhat-linux-gnu’ ‘–target=i386-redhat-linux-gnu’ ‘–program-prefix=’ ‘–prefix=/usr’ ‘–exec-prefix=/usr’ ‘–bindir=/usr/bin’ ‘–sbindir=/usr/sbin’ ‘–sysconfdir=/etc’ ‘–datadir=/usr/share’ ‘–includedir=/usr/include’ ‘–libdir=/usr/lib’ ‘–libexecdir=/usr/libexec’ ‘–localstatedir=/var’ ‘–sharedstatedir=/usr/com’ ‘–mandir=/usr/share/man’ ‘–infodir=/usr/share/info’ ‘–cache-file=…/config.cache’ ‘–with-libdir=lib’ ‘–with-config-file-path=/etc’ ‘–with-config-file-scan-dir=/etc/php.d’ ‘–disable-debug’ ‘–with-pic’ ‘–disable-rpath’ ‘–without-pear’ ‘–with-bz2’ ‘–with-curl’ ‘–with-exec-dir=/usr/bin’ ‘–with-freetype-dir=/usr’ ‘–with-png-dir=/usr’ ‘–enable-gd-native-ttf’ ‘–without-gdbm’ ‘–with-gettext’ ‘–with-gmp’ ‘–with-iconv’ ‘–with-jpeg-dir=/usr’ ‘–with-openssl’ ‘–with-png’ ‘–with-pspell’ ‘–with-expat-dir=/usr’ ‘–with-pcre-regex=/usr’ ‘–with-zlib’ ‘–with-layout=GNU’ ‘–enable-exif’ ‘–enable-ftp’ ‘–enable-magic-quotes’ ‘–enable-sockets’ ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-sysvmsg’ ‘–enable-track-vars’ ‘–enable-trans-sid’ ‘–enable-yp’ ‘–enable-wddx’ ‘–with-kerberos’ ‘–enable-ucd-snmp-hack’ ‘–with-unixODBC=shared,/usr’ ‘–enable-memory-limit’ ‘–enable-shmop’ ‘–enable-calendar’ ‘–enable-dbx’ ‘–enable-dio’ ‘–with-mime-magic=/usr/share/file/magic.mime’ ‘–without-sqlite’ ‘–with-libxml-dir=/usr’ ‘–with-xml’ ‘–with-system-tzdata’ ‘–enable-force-cgi-redirect’ ‘–enable-pcntl’ ‘–with-imap=shared’ ‘–with-imap-ssl’ ‘–enable-mbstring=shared’ ‘–enable-mbstr-enc-trans’ ‘–enable-mbregex’ ‘–with-ncurses=shared’ ‘–with-gd=shared’ ‘–enable-bcmath=shared’ ‘–enable-dba=shared’ ‘–with-db4=/usr’ ‘–with-xmlrpc=shared’ ‘–with-ldap=shared’ ‘–with-ldap-sasl’ ‘–with-mysql=shared,/usr’ ‘–with-mysqli=shared,/usr/bin/mysql_config’ ‘–enable-dom=shared’ ‘–with-dom-xslt=/usr’ ‘–with-dom-exslt=/usr’ ‘–with-pgsql=shared’ ‘–with-snmp=shared,/usr’ ‘–enable-soap=shared’ ‘–with-xsl=shared,/usr’ ‘–enable-xmlreader=shared’ ‘–enable-xmlwriter=shared’ ‘–enable-fastcgi’ ‘–enable-pdo=shared’ ‘–with-pdo-odbc=shared,unixODBC,/usr’ ‘–with-pdo-mysql=shared,/usr’ ‘–with-pdo-pgsql=shared,/usr’ ‘–with-pdo-sqlite=shared,/usr’ ‘–enable-dbase=shared’
CURL Information => libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

( a of a long reply ! )


> php -i | grep GD
GD Support => enabled
GD Version => bundled (2.0.28 compatible)

So I guess they are both up and running ?

Yup, looks like your server has both of those installed!