Changing web root in templete not workin?

Hey there! Just follow the instructions and changed the template “Website for domain” section. Set the DocumentRoot to ${HOME}/public and <Directory ${HOME}/public>. Then created a new Virtual Server and the directory is the same old public_htlml instead of the new “public”.

Any ideas?

Hello,

@juan.borras If you use Virtualmin with Apache you should also change public_html entry in the template above to public, e.g.:

I personally find this a bit confusing and redundant. @Jamie, should we just update the textbox with Apache template automatically when changing html_dir option in Virtualmin templates page? It isn’t hard to do.

Maybe we should instead just change the “Website subdirectory to create” field to have an “Automatic” option which gets it from the Apache config template?

Hey! Thanks! I missed the “User’s website subdir to create” option!

Sorry!!

Yeah it’s easier, and it could work just great too! I thought to keep it consistent with Nginx at first.

Same the problem is here with me.

did you read

and the bit the OP missed

That fixes it

yes! the choice of webserver used is secondary

@Jamie, where we at about this?

It’s on my TODO list!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.