Changing quota doesn't work

I have migrated my mail server from ensim to virtualmin last years.
Found a problem with some of the sites when they hits their quota.

The steps I used is to increase the particular domain quota and advice the user to clear up their emails.

I edited the quota under “Edit Virtual Server” > “Quotas and limits” > Change both total server quota and server administrator’s quota.

===First sign of trouble comes when it says===
Modifying administration user …
… Administration user failed! :

===Second sign of trouble comes with I tried to Validate Virtual Servers===
Administration user : Unix group domainadmin’s quota of 550 MB does not match the virtual server’s quota of 650 MB

Even if I goes into Webmin and change the domainadmin quota of 650 the same error still occurs, and nobody in the domain is able to access or receive emails, etc.

Help plz!


Hrm, yeah, something there is awry. It’s possible the quota managed to get out of sync. What happens if you go into Limits and Validation -> Check Disk Quotas, and run “Check Now”.

Then, if you run “quota -v USERNAME”, from the command line does the quota show up correctly?

Now, go into Edit Virtual Server and try changing the quota again.

Does that work this time?


I’ll look through my hosted domain and try your method on one that’s giving the same problem.

Anyway, I troubleshooted yesterday and found that I had to go to the Webmin and change the Group quota for that particular domain for everything to work. :confused: Need more testing out~