Changing ports in the Email Client Settings

SYSTEM INFORMATION
OS type and version Debian 11
Webmin version 2.001
Virtualmin version 7.2-1

Hi Guys,

I’m trying to change the ports in my Virtualmin “View Email Client Settings”.
I want to change the 587 port to 465 and for the Encryption type “SSL/TLS”.
Is there a way to configure this screen in Virtualmin? I haven’t found any option for it. I don’t know, maybe it’s hard-coded? Or I just can’t see the option?

Thanks already a lot

Fabi

I think that all you have to do is enable sasl_auth in Postfix and open port 465 in the firewall. Don’t take that as gospel, though. Postfix is one of my weaker areas. But that’s all I remember changing when I had to do it a year or two ago.

Hopefully someone will come by and either verify or correct my answer.

Richard

Hi @RJM_Web_Design, thanks a lot for your answer :wink:

Yes, actually everything is working so far with postfix and Outlook. I can access port 465 without problems by using TLS/SSL.
I’m just looking for a solution to change the data on the “View Email Client Settings” to change it there. Since I’ll probably forget about it in a few days, it might be better for me to have it written down :grin:
But it looks like in this mask, all the data is hard-coded.
I have checked every corner of Virtualmin and Webmin, but I haven’t found any settings which will affect this mask.
But it’s not a big problem, I have to write it down to remember in a few weeks. It looks like here in the EU, we should better connect through the TLS/SSL port, since with the Starttls the email could be send out under some circumstances without SSL and as far as I understood it right, that’s something against the EU law :roll_eyes:

Have all of you a great Sunday today :wink:

I think smtpd_tls_auth_only = yes will force a secure connection. Again, you may want to double-check me on that.

You have a great Sunday, too.

Richard

Thanks a lot Richard @RJM_Web_Design for your hint.

I’ll definitely try it on my Testserver and see what it does :+1:

Thanks again for you help :slightly_smiling_face: