Changing PHP version for FPM no longer working

I did a clean install of Virtual Min GPL on two servers with CentOS 8. Everything worked fine around 3 weeks ago.
Since around one week on this two servers I get this message, if I try to change the PHP version for FPM.

Failed to save PHP versions : Apache virtual host was not found

I am really sure that there is nothing really wrong on the server config, because one of the server hast just 2 domains without doing any harder configuration on it.

I tried it on a server in my office, using Ubuntu and Virtual Min, and got the same message. It seems to be a bug in Virtualmin. Is there any workaround for it?

Operating system: CentOS
OS version 8:

This is a duplicate of a message from earlier today:

OK - but I do not change from Fcgi to FPM - I just try to change the PHP version while using FPM. Not sure if this is the same problem.

You are right. Perhaps my use of the word duplicate was not correct. The error message is the same in both cases - i.e Apache virtual host was not found and the advent of the error has coincided with the release of the newest versions of Webmin and related software.

I am sure the devs are looking into it.

Unfortunately it’s a bug and we just fixed it. It’s false positive though. Expect it to be fixed with Virtualmin 6.14.

You can apply this change manually by editing /usr/share/webmin/virtual-server/ file and restarting Webmin with /etc/webmin/restart command.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.