Changing IP address of a virtual server which already has an active ssl

Hi, I phurcased and activated a new IP than I changed on a virtual server using the change IP address tab in virtualmin but the site already has ssl using the share IP address of the server. So now when I paste the domain name in browser I get the insecure messagge, than I switched back to the shared IP but I would like to add the new IP address. The new dedicated IP is active and working Im having a dedicated server from ovh the only problem here is ssl.

To do this job should I phurcase a new ssl certificate or there is any trick that I can do?

as I see when I change the vistual server IP from Change IP Address Section its showing ssl of another virtualserver
So I have 4 virtualserver and a comodo ssl for each one with one shared ip at all, when I change the IP of domain x its automaticaly showing the ssl of the domain y and the error messagge says that page is insecure because this certificate is valid only for domain y so something that I cannot understand.


Im doing anything wrong here? I never get a response this is not the first time.
However thankyou.

Did you update the DNS for that website to the new IP address?

I changed it on virtual server > change IP address and nothing else is there any other step to do?

first of all I added a new virtual interfacewatching this video as eth0:0 than after the boot the IP came activated than I added in change ip address tab of the virtual server and it worked but the only problem is the ssl when I change it the ssl not working any more if there other steps to do please let me know thankyou for our reply.

Does Virtualmin manage the DNS for that site, or somewhere else? Have you checked that the site resolves to the new IP?

when I ping the domain name I see the old IP but when I type the domain name on browser its working without ssl when I switch back to the old IP address in that tab it works with ssl again so with the shared ip its working

Update your DNS record for that site. Afterward, you’ll have to wait a while for the old cached record to expire (how long depends on your DNS settings). That should fix your problem.

you mean virtual server > server configuration > DNS records? Im sorry noisemarine this is the first time and I never worked with additional IPs
Should I point the IP adress on one of the nameservers or domain (Virtual Server > Server Configuration > Change IP Address)? I did correct or should I go on any other tab to finish the process?

Yes, go into DNS Records, presuming that your Virtualmin server handles DNS for that site. You should edit any records that have the old IP address.

Thankyou noisemarine I changed all fields where have the old IP to the new IP but on the top I have an error with the red text
Warning - errors were found in this domain’s DNS records : The DNS record resolves to the IP address xxx.xx.xx.xx instead of the virtual server’s IP xxx.xx.xx.xx

Now Im afraid to restart httpd because it will fail Im sure. However thankyou.

Does Virtualmin-> -> Edit Virtual Server have the right IP address?

Yes sure its the first step that I did and when I paste the new IP address on browser It sends me to the domain but with a wrong ssl instead of its own ssl certificate

its showing ssl of another virtual server on the same machine and the domain is not valid than site is insecured thats all why Im so crazy here.

edit virtual server > showing: IP addresses newIP, ipv6:: (OLDIP externally)

Disabled IPv6 and external IP in change IP Address Section and now dns records saved successfully with the new IP address now I will wait because still getting insecured error on domain.

The Default Cache Time at the top of the DNS zone should give you an idea of how long you have to wait (in seconds). Anyone that hasn’t looked up your site before should see things properly straight away.