Changing hostname error message

---------------------- ---------------------------
OS type and version AlmaLinux 9.3
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

Posting this again based on original question here:

I still can’t change the hostname. A search of the forums doesn’t seem to supply any ready answers. When I go to save i get the following error.

Failed to save DNS configuration : nmcli conn modify 561c512c-29ef-4f1a-8aaa-d08800e93db8 ipv4.addresses ipv4.method manual failed : Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don’t match. Restarting NetworkManager is advised. Error: Failed to modify connection ‘eth0’: connection.autoconnect-ports: unknown property

It seems like the CLI version differs from the package verison? A bit like when phpCLI is a version behind the one used in serving websites.
Is there a solution to this?

Is this Webmin issue? Did you try restarting NetworkManager service?

Brilliant that worked!
Although it took me to the network configuration manager apply settings page afterwards. Is it necessary to reapply this for change to be complete?

Yes, it is necessary.

Thank you Ilia. All sorted now.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.