Changing domain name causes some problem on my browser only

Operating system: Ubuntu
OS version: 18.04

The website is built with wordpress. The original site’s domain name is, last week I changed it to I have also changed the setting and updated the database. I believe I have changed all occurences of “” in the database to “”. I am not sure if there is cache somewhere but one week has passed and when I open in my browser, it still goes to and open the default server in this IP. But if I get into incognito mode or open it with another browser, this problem will be no more. Not a big deal cause it doesn’t affect my users but it is quite bothering for me cause every time I had to use incognito mode to access my own site, also there might also be some potential problems somewhere.

I am not sure if this is a wordpress problem or a virtualmin problem, so I will also post this question to wordpress forum.

Have you emptied your browser cache from all time? If not, that’s what’s doing it. Also, if you’re running Cloudflare, make sure you empty that cache as well.

There are also Wordpress plugins like W3 total cache that need to be emptied as well. There’s also the General Settings in Wordpress where you enter your web address and website name. Make sure that’s updated too.

Whenever you make a big change like that empty every cache you have be it your browser, any caching plugins you have, Cloudflare, all of it.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.