changing domain admin's login permissions

I cant change the “login permissions” of an already setup domain admin via Virtualmin/Edit Mail and FTP Users directly but via Webmin/System/Users by changing the shell to the ones given in Virtualmin/System Customization/Custom Shells … after that change the permission shown in Virtualmin is e.g. “/bin/false” instead of “Email and FTP”. <edit>The permissions are shown correctly as soon as the shell is enabled in Custom Shells</edit>.

Is there any other way to change the permissions or to fix that behavior?


Hmm… if you go into Edit Mail and FTP Users, click a username, then go into the “Other user permissions” section, there’s an option named “Login Permissions”.

Do you have that option? And if so, what happens if you try to change that?


[…] there’s an option named “Login Permissions”. […]

Being logged in as Master Admin this option is only available for “normal” users and isn’t shown for the virtual server’s administrator.

2nd: if I disabled the Custom Shells “FTP” (/bin/false) for mailusers I can’t set them to FTP afterwards … even being logged in as Master Admin. Changing the shell for a user via Webmin/Users enables that user for FTP, but in the permission dropdown (Virtualmin/Users) it’s shown as “/bin/false”, not “Mail and FTP”.

It would be nice if it would be possible for Master Admins to set users’s shells of a virtuals server to FTP/SSH even the custom shells are disabled (which disables only the option for Domain Admins) …

So: there are 2 dropdowns missing.