Change Timezome and Time Server Sync pages are blank

In Webmin -> Hardward -> System Time, the tabs for Change Timezome and Time Server Sync pages are blank. This is on all my Virtualmin servers. They are with Linode so are likely VPS’s or similar.

I dont know if its related but I have a newsletter system that uses cron and it keeps saying my cron job has not run for the past 3 times (but i think the cron job is running). It does then send newsletters about 2 hours later, hence me investigating timezone issues. I have changed the timezone to BST in the command line by symlinking localtime to Europe/London:
ln -sf /usr/share/zoneinfo/Europe/London /etc/localtime

But my newsletter system has some strange things going on with cron and times. It worked Ok in the old server (just moved it to this Virtualmin server last night).

Forget about my newsletter system issues… PHP.ini was set to Europe/London, so the cron job was registering at that time, but the newsletter system settings do not have this timezone, just GMT, so it was 1 hour different and causing issues with cron status reports and sending newsletters. Had to change the server timezone to UTC to match the newsletter system which is a shame.

So the issue is just not being able to change timezone in Webmin due to the screen being blank.

Oh just realised maybe this should be in the webmin forum sorry.

Do you see any errors in the Webmin error log, /var/webmin/miniserv.error?

Also, you may want to verify that you have NTP installed.


I’m sorry I should have added that, as I saw this question on another thread…

The only error I get is:
Error: hwclock failed :

Which I thought was because I am on a VPS controlled my Linode so dont have access to the hardware?

Jamie had attempted to fix the issue you’re describing a few Webmin versions ago.

Which Webmin version is it that you’re using?

If it’s not the latest, you may want to try upgrading, as that may resolve the issue you’re having.


Sorry for late reply, been a bit hectic…

Its the latest version, Webmin 4?, this has been happening for a long time I only reported it now.


That sounds like the Virtualmin version… can you verify that your system has the most recent Webmin as well?

You can check that by logging into Virtualmin, and on that initial System Information screen, it shows your Webmin version right under the System Hostname.



Sorry got confused, but it is all up to date…

Virtualmin 4
Webmin 1.630
Theme 8.7
Kernel and CPU Linux 3.9.3-x86-linode52 on i686
Centos 6.4

Is there anything else we can look at for this?

For info, I use Linode. I emabled their new Longview monitoring service for one of my servers. They report this message at the top:

Your system’s clock is fast. Please ensure that ntp is installed and running.

Do you think this is related?


Edit: I started ntp in Boot Up and Shutdown, but Change Timezone and Time Server Sync, still give me a blank page.

Edit of Edit: If I also start ntpdate, I get this message “ntpdate: Synchronizing with time server: [FAILED]”


I don’t think that’s related… you could try running this command as root from the command line to see if it’s able to set the time:


I get this:

31 Jul 13:32:18 ntpdate[22598]: the NTP socket is in use, exiting

Ah, it sounds like you’re currently running the NTP daemon… you may need to first stop that daemon, and then run the ntpdate command.


Ah yes I started it earlier…

So I stopped it and now get this:

31 Jul 14:22:04 ntpdate[25302]: adjust time server offset 0.011885 sec

Does anyone have any more ideas about this issue?

I really want to get the server times working right because at the moment the server times are set to one hour behind the actual summer time here, which messes some things up for people like cron jobs, newsletter scheduling and Amazon S3 APIs (it requires server time to be the same). Ideally I want my server times to be the same as the actual time, and then also adjust automatically with daylight saving. But I cant access the timezone settings.

Any update on this please?

I would ideally like to set the time on my servers to the correct time which is UK summertime and have them change this automatically when the clocks change. Is this not possible? I cant tell as my Change Timezone and Timeserver sync pages are both blank for ALL my servers, not just Linode, I have two on Amazon EC2 and they are blank.

Not being able to do this is really messing up cron jobs and newsletter schedules.


You might want to turn on the Webmin debug log in its settings, to see what commands it tries to execute when you load the blank pages. Otherwise it’s just guessing what could be wrong, and as you can see, no one (not even Eric) has an idea right now. :slight_smile:

NOt quote sure what I am looking at but cant see any error statements…

11565 [16/Sep/2013 08:27:31.723647] root time READ “/etc/sysconfig/clock”
11565 [16/Sep/2013 08:27:32.697185] root - STOP “runtime=1”
11564 [16/Sep/2013 08:27:34.199463] - - START “script=save_log.cgi”
11564 [16/Sep/2013 08:27:34.199747] - - READ “/etc/webmin/miniserv.conf”
11564 [16/Sep/2013 08:27:34.200429] root - READ “/etc/webmin/syslog/config”
11564 [16/Sep/2013 08:27:34.200904] root - READ “/usr/libexec/webmin/virtual-server-theme/config”
11564 [16/Sep/2013 08:27:34.203131] root - READ “/etc/webmin/custom-lang”
11564 [16/Sep/2013 08:27:34.203928] root - READ “/etc/webmin/syslog/custom-lang”
11564 [16/Sep/2013 08:27:34.205068] root - READ “/etc/webmin/module.infos.cache”
11564 [16/Sep/2013 08:27:34.247718] root - READ “/usr/libexec/webmin//defaultacl”
11564 [16/Sep/2013 08:27:34.248131] root - READ “/etc/webmin/root.acl”
11564 [16/Sep/2013 08:27:34.248468] root - READ “/etc/webmin//root.acl”
11564 [16/Sep/2013 08:27:34.248852] root - READ “/etc/webmin/installed.cache”
11564 [16/Sep/2013 08:27:34.251824] root - READ “/usr/libexec/webmin/syslog/”
11564 [16/Sep/2013 08:27:34.252532] root - READ “/etc/webmin/webmin.cats”
11564 [16/Sep/2013 08:27:34.252796] root - READ “/etc/webmin/webmin.descs”
11564 [16/Sep/2013 08:27:34.255253] root syslog READ “/usr/libexec/webmin/syslog/defaultacl”
11564 [16/Sep/2013 08:27:34.255638] root syslog READ “/etc/webmin/syslog/root.acl”
11564 [16/Sep/2013 08:27:34.265099] root - READ “/etc/webmin/proc/config”
11564 [16/Sep/2013 08:27:34.266665] root - READ “/etc/webmin/proc/custom-lang”
11564 [16/Sep/2013 08:27:34.295161] root proc READ “/usr/libexec/webmin/proc/defaultacl”
11564 [16/Sep/2013 08:27:34.295569] root proc READ “/etc/webmin/proc/root.acl”
11564 [16/Sep/2013 08:27:34.295991] root syslog READ “/etc/rsyslog.conf”
11564 [16/Sep/2013 08:27:34.366727] root syslog READ “/etc/sysconfig/network”

It was a configuration issue as per the bug report here:

Need to set system System supports hardware time = No in System Time -> Module config -> System configuration