change shared ip to private ip for ssl, problem

hi there

i have a running domain which needs ssl. there will be more then one domain with ssl. i have failover ips from my provider ( which are pointing to my server.

i tried to follow the documentation:

unfortunately if i try to add another shared ip i get:
“Failed to save shared IP addresses : No free IP addresses were found in the allocation range none”

i think i do not have a range, because all my ips look quite different.

After that i found a way to add a virtual interface eth0:0 in webmin with the according ip. after that i added a virtual server for testing with this ip and i was able to setup a working index.html. the routing looks ok.

i tried now to change the ip of a running virtual server. unfortunately this does not really work, somehow this points to my default virtual server, i guess the first one created and not to the target virtual server.

i don’t get this. why is it possible to start a fresh virtual server with a private ip, but not to change a server from a shared ip to a private one?

i guess this should not be that big issue, but what am i missing?

any ideas?



You can add an IP address to a Virtual Server by going into Server Configuration -> Change Address, and setting the new IP address to use there.


i added the ip there. does the ip have to be added as virtual interface on eth0:1, or can i just enter this ip there, as it is public an pointing to the server.

if i add it there it points to my default page, not to the one of the according virtual server.



You may be dealing with a DNS propagation issue… the old IP address may be cached in your DNS.

If you try it from a computer that uses a different DNS provider, does it work there?

If the DNS is cached, it could take a day or two to update to the new IP.


i added the ip in my locale host-file, therefor i should avoid this DNS issues.

might it be that our local DNS server running on the same system/server as virtualmin (i know, not really a good idea, we will change this) might be the problem?

is there a way for a work around, at least to test things without waiting two days? i thought with a simple entry in my local host file i would avoid this issues.

thanks for helping out


Same issue for me:
I have a domain that I need to migrate to SSL. This domain uses an IP and it is the only one to use this IP. But this IP is defined as SHARED. so I need to define it as PRIVATE.
How can I achieve that?