Change home directory, error 500

Hi i’m trying to Change home directory /home/ to /home/hdd/
I go to the section Virtualmin > Server Configuration > Change Domain Name | Change home directory? | New directory = /home/hdd/ and apply. All successfully applied correctly without errors.
But it stops working correctly php, gives me an error 500 internal server error.
how to fix it ?
Virtualmin 3.98
OS debian 6.0.7


After receiving that Internal Server Error, what error shows up in your Apache logs in $HOME/logs/error_log?


[Thu Mar 14 21:21:10 2013] [warn] [client] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Thu Mar 14 21:21:10 2013] [error] [client] Premature end of script headers: index.php

Hmm, that error unfortunately doesn’t explain much about what’s going on.

Another thing to try would be to go into Server Configuration -> Website Options for this domain, and to change the PHP Execution Mode to “CGI”. That will often provider better error messages.


I changed it to CGI

[Thu Mar 14 23:23:16 2013] [error] [client] suexec policy violation: see suexec log for more details
[Thu Mar 14 23:23:16 2013] [error] [client] Premature end of script headers: php5.cgi

suexec log

[2013-03-14 23:23:16]: uid: (1044/asura) gid: (1020/asura) cmd: php5.cgi
[2013-03-14 23:23:16]: (13)Permission denied: exec failed (php5.cgi)

I tried to change chmod 777 on folder $HOME/cgi-bin/ and /fcgi-bin/

chmod: changing permissions of asura/cgi-bin/php5.cgi': Operation not permitted chmod: changing permissions of asura/fcgi-bin/php5.fcgi’: Operation not permitted

it did not help