Change group for sub-domain

Using the GPL version, sub-domain groups were set as domain.subdomain. When I restored into the Pro version it reset the sub-domain group to the parent, but I need to keep the sub-domain users separate from the parent group. I don’t see a way to change the sub-domain group back to the way the GPL version set it up. It would be nice to be able to change this…

Any chance I can get a reply to this? I really need to have the groups set, or be able to change them. I currently have to do it manually, which means users don’t show in VMin

Hmmm…I’m not seeing a way to change this, after creation, either. I’ll ask Jamie to have a look at this thread, to get his thoughts.

In Virtualmin pro, all mail users in a parent domain and its sub-domains have the same primary group. This is done so that group quotas can be used to apply a quota to all members of the group, thus setting an upper limit on the disk space a domain administrator and all his mail users can use.

This is unlikely to change in future, as there would be no way to properly enforce quotas. If you really want users in different domains to have different groups, this is best done by creating two parent virtual servers with separate admin logins.

By the way, it is possible for both foo.com and bar.foo.com to both be parent servers, if that is what you are looking for.

I use the different groups for FTP access (DefaultRoot directory group in ProFTP). GPL seemed to automatically create a different group for the sub-servers. The reason is that some sub-servers should be able to FTP into the parent server. I will look into making it a parent, but it would be nice to at least assign a group during creation. That way I can have a separate group and still backup correctly.
For the domains I have already changed manually, the group shows correctly on the server setting page, but there are no users. Have I just scrambled everything?

I meant shouldn’t be able to FTP into the parent

If you want sub-server users to be able to FTP into the parent server’s files, have you tried making the files group-writable?
Perhaps you could let me know exactly what problem you are trying to solve, as there may be a solution other than changing the groups (which will likely confuse Virtualmin).