Change document root of virtual server -> lost ability to set PHP fcgid in website option

Hi,

I run Debian 10 + Usermin 1.823 + Apache 2.4
I need to change Doccument Root of a virtual server from /home/username/public_html to /home/username/public_html/pub
I do this in Webmin > Server > Apache Server > edit directives > change the Document Root line to /home/username/public_html/pub and reload service.
It worked.

However, after changing that, in Virtualmin > Server Configuration > PHP Options , I don’t see option to set website to use PHP 7.4 fcgid anymore, the only option left there is mod_php 7.0 the out of the box default one. It seems virtualmin cannot read the configuration for fcgid anymore after I change document root.
Can you suggest a way to make it read the correct configuration again? Thank you

1 Like

I don’t know the answer, off-hand, but this jumps out:

You should not have mod_php enabled. It shouldn’t even be installed.

I’d recommend you uninstall it.

I don’t use mod_php, true. But virtualmin only display that option because it doesn’t read any other php mode after document root is updated. I think this is a bug of virtualmin when you change doc root of a virtual server. What I want is to be able to select mode Php fcgid again in PHP Options.
Can you try to change document root of one virtual server to see if it happens? Thank you