Centos & RedHat 8 installation results

hello all -

i ran into quite a few issues, but i believe i have successfully installed on centos/rh 8

below is a quick overview of what i ran into, including the extra commands required to get the installation to work.

NOTE: i was installing each time on a new google-cloud VPS, to ensure a fresh OS.


                   ## you may want to carefully look at SELinux.
setenforce permissive ;   ## this should be made permanent in /etc/selinux/config
getenforce ;    ### double-check


dnf  --assumeyes  install      wget  gcc     pam-devel     ;
dnf  module  --assumeyes   install perl:5.26         ; 
dnf                        install perl-CPAN         ;
dnf          --assumeyes   install perl-open.noarch  ; 
PERL_MM_USE_DEFAULT=1 cpan -i CPAN  ;  ## initialize cpan for first run
/usr/bin/cpan    -i     Authen::PAM   ;  

https://github.com/webmin/webmin/pull/1218  -- fix setup.sh script 
https://github.com/webmin/webmin/pull/1222  -- fix PIDFile /usr/lib/systemd/system/webmin.service


  ## interesting situation - webmin is running before systemctl knows about it.  I found it best to stop 
 ## webmin manually before proceeding.
kill -9 $(pgrep miniserv; )  ##  kill the one started by the installation process
systemctl enable webmin.service ;
systemctl stop webmin.service ;    ## just in case....
systemctl start webmin.service ;
systemctl status webmin.service ;   ## double check


systemctl stop firewalld.service ;   ## virtualmin  appears to only complete if the firewall is temporarily down

virtuamin:  (had to run this several times)

https://github.com/virtualmin/virtualmin-install/pull/31  -- suppress PowerTools for redhat

This installation is still more difficult than it should be, given how easy Centos 6&7 are. But once this matures a bit, hopefully these issues will be resolved.

mesage about running install multiple times:

Virtualmin may already be installed. This can happen if an installation failed,
 and can be ignored in that case.

EDIT: i am wondering if the error on the step:

[20/23] Configuring Webmin” : “Error: Failed to restart Webmin server!

is because of how webmin is somehow starting internally rather than using systemctl ?

in other words, when i enter systemctl stop webmin.service, often times i also have to enter:
kill -9 $(pgrep miniserv; )
and i am wondering if there is a way around this?

note that when i run several times and rely on “luck” to complete the virtualmin install, i get this status message:
PID 13465 from file /var/webmin/miniserv.pid is not valid
This was the same error message i was receiving using systemctl until i created this PR.

i believe i have resolved this issue: https://github.com/webmin/webmin/pull/1223

EDIT: it sounds as if the Virtualmin people are taking care of this internally.