CentOS 7 yum update problem

Hello!

It seems that the CentOS 7 repos are somehow not correct. I tried to do an update and get the following:

[root@vmi377627 ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Excluding mirror: mirror.fra10.de.leaseweb.net
 * base: asi-fs-n.contabo.net
 * centos-sclo-rh: mirror.scaleuptech.com
 * centos-sclo-sclo: ftp.wrz.de
Excluding mirror: mirror.de.leaseweb.net
Excluding mirror: mirror.nl.leaseweb.net
 * epel: mirror.infonline.de
 * extras: mirror.scaleuptech.com
 * remi-php56: remi.schlundtech.de
 * remi-safe: remi.schlundtech.de
Excluding mirror: mirror.fra10.de.leaseweb.net
 * updates: asi-fs-n.contabo.net
Resolving Dependencies
--> Running transaction check
---> Package dbus.x86_64 1:1.10.24-13.el7_6 will be updated
---> Package dbus.x86_64 1:1.10.24-14.el7_8 will be an update
---> Package dbus-libs.x86_64 1:1.10.24-13.el7_6 will be updated
---> Package dbus-libs.x86_64 1:1.10.24-14.el7_8 will be an update
---> Package gd-last.x86_64 0:2.3.0-1.el7.remi will be updated
---> Package gd-last.x86_64 0:2.3.0-2.el7.remi will be an update
---> Package libzip5.x86_64 0:1.7.2-1.el7.remi will be updated
---> Package libzip5.x86_64 0:1.7.3-1.el7.remi will be an update
---> Package usermin.noarch 0:1.791-1 will be updated
---> Package usermin.noarch 0:1.802-1 will be an update
---> Package wbm-ruby-gems.noarch 2:1.6-1 will be updated
---> Package wbm-ruby-gems.noarch 2:1.7-1 will be an update
---> Package wbm-virtual-server.noarch 2:6.10.gpl-1 will be updated
---> Package wbm-virtual-server.noarch 3:6.10.gpl-2 will be an update
---> Package wbm-virtualmin-awstats.noarch 2:5.8-1 will be updated
---> Package wbm-virtualmin-awstats.noarch 2:5.9-1 will be an update
--> Processing Dependency: wbm-software for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
--> Processing Dependency: wbm-cron for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
---> Package wbm-virtualmin-dav.noarch 2:3.10-1 will be updated
---> Package wbm-virtualmin-dav.noarch 2:3.11-1 will be an update
---> Package wbm-virtualmin-git.noarch 0:1.10-1 will be updated
---> Package wbm-virtualmin-git.noarch 0:1.12-1 will be an update
--> Processing Dependency: wbm-htaccess-htpasswd for package: wbm-virtualmin-git-1.12-1.noarch
---> Package wbm-virtualmin-htpasswd.noarch 2:2.8-1 will be updated
---> Package wbm-virtualmin-htpasswd.noarch 2:2.9-1 will be an update
--> Processing Dependency: wbm-htaccess-htpasswd for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
--> Processing Dependency: wbm-apache for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
---> Package wbm-virtualmin-init.noarch 2:2.7-1 will be updated
---> Package wbm-virtualmin-init.noarch 2:2.8-1 will be an update
--> Processing Dependency: wbm-init for package: 2:wbm-virtualmin-init-2.8-1.noarch
---> Package wbm-virtualmin-registrar.noarch 2:2.7-1 will be updated
---> Package wbm-virtualmin-registrar.noarch 2:2.8-1 will be an update
---> Package wbm-virtualmin-slavedns.noarch 2:1.10-1 will be updated
---> Package wbm-virtualmin-slavedns.noarch 2:1.11-1 will be an update
--> Processing Dependency: wbm-bind8 for package: 2:wbm-virtualmin-slavedns-1.11-1.noarch
--> Finished Dependency Resolution
Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
           Requires: wbm-apache
Error: Package: 2:wbm-virtualmin-slavedns-1.11-1.noarch (virtualmin-universal)
           Requires: wbm-bind8
Error: Package: wbm-virtualmin-git-1.12-1.noarch (virtualmin-universal)
           Requires: wbm-htaccess-htpasswd
Error: Package: 2:wbm-virtualmin-init-2.8-1.noarch (virtualmin-universal)
           Requires: wbm-init
Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
           Requires: wbm-cron
Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
           Requires: wbm-htaccess-htpasswd
Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
           Requires: wbm-software
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It seems to me that some virtual package names are not coherent between universal and CentOS 7 release specific repos.

Anyone else have the same?

Thanks,

Andras

I’m getting the same exact error for CentOS 6.10.

Hi,

I have the same problem :

–> Traitement de la dépendance : wbm-bind8 pour le paquet : 2:wbm-virtualmin-slavedns-1.11-1.noarch
–> Résolution des dépendances terminée
Erreur : Paquet : 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
Requiert : wbm-htaccess-htpasswd
Erreur : Paquet : 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
Requiert : wbm-cron
Erreur : Paquet : 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
Requiert : wbm-software
Erreur : Paquet : wbm-virtualmin-git-1.12-1.noarch (virtualmin-universal)
Requiert : wbm-htaccess-htpasswd
Erreur : Paquet : 2:wbm-virtualmin-slavedns-1.11-1.noarch (virtualmin-universal)
Requiert : wbm-bind8
Erreur : Paquet : 2:wbm-virtualmin-init-2.8-1.noarch (virtualmin-universal)
Requiert : wbm-init
Erreur : Paquet : 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
Requiert : wbm-apache
Vous pouvez essayer d’utiliser --skip-broken pour contourner le problème
Vous pouvez essayer d’exécuter : rpm -Va --nofiles --nodigest

Bruno

CentOS Linux 7.8.2003 - same errors.

Same. CentOS Linux 7.8.2003

Same error CentOS7

Yep. Here’s mine.

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.cs.vt.edu
 * centos-sclo-rh: mirror.centos.iad1.serverforge.org
 * centos-sclo-sclo: mirror.vcu.edu
 * epel: ewr.edge.kernel.org
 * extras: mirrors.advancedhosters.com
 * updates: linux.cc.lehigh.edu
Resolving Dependencies
--> Running transaction check
---> Package usermin.noarch 0:1.791-1 will be updated
---> Package usermin.noarch 0:1.802-1 will be an update
---> Package wbm-ruby-gems.noarch 2:1.6-1 will be updated
---> Package wbm-ruby-gems.noarch 2:1.7-1 will be an update
---> Package wbm-virtualmin-awstats.noarch 2:5.8-1 will be updated
---> Package wbm-virtualmin-awstats.noarch 2:5.9-1 will be an update
--> Processing Dependency: wbm-software for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
--> Processing Dependency: wbm-cron for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
---> Package wbm-virtualmin-dav.noarch 2:3.10-1 will be updated
---> Package wbm-virtualmin-dav.noarch 2:3.11-1 will be an update
---> Package wbm-virtualmin-git.noarch 0:1.10-1 will be updated
---> Package wbm-virtualmin-git.noarch 0:1.12-1 will be an update
--> Processing Dependency: wbm-htaccess-htpasswd for package: wbm-virtualmin-git-1.12-1.noarch
---> Package wbm-virtualmin-htpasswd.noarch 2:2.8-1 will be updated
---> Package wbm-virtualmin-htpasswd.noarch 2:2.9-1 will be an update
--> Processing Dependency: wbm-htaccess-htpasswd for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
--> Processing Dependency: wbm-apache for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
---> Package wbm-virtualmin-init.noarch 2:2.7-1 will be updated
---> Package wbm-virtualmin-init.noarch 2:2.8-1 will be an update
--> Processing Dependency: wbm-init for package: 2:wbm-virtualmin-init-2.8-1.noarch
---> Package wbm-virtualmin-registrar.noarch 2:2.7-1 will be updated
---> Package wbm-virtualmin-registrar.noarch 2:2.8-1 will be an update
---> Package wbm-virtualmin-slavedns.noarch 2:1.10-1 will be updated
---> Package wbm-virtualmin-slavedns.noarch 2:1.11-1 will be an update
--> Processing Dependency: wbm-bind8 for package: 2:wbm-virtualmin-slavedns-1.11-1.noarch
--> Finished Dependency Resolution
Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
           Requires: wbm-apache
Error: Package: 2:wbm-virtualmin-slavedns-1.11-1.noarch (virtualmin-universal)
           Requires: wbm-bind8
Error: Package: wbm-virtualmin-git-1.12-1.noarch (virtualmin-universal)
           Requires: wbm-htaccess-htpasswd
Error: Package: 2:wbm-virtualmin-init-2.8-1.noarch (virtualmin-universal)
           Requires: wbm-init
Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
           Requires: wbm-cron
Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
           Requires: wbm-htaccess-htpasswd
Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
           Requires: wbm-software
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I tried a new install yesterday. It was successful.
Today I did a new install on another VM.
I can’t install with the same error.

Same for me on CentOS 8

Resolving Dependencies
--> Running transaction check
---> Package usermin.noarch 0:1.791-1 will be updated
---> Package usermin.noarch 0:1.802-1 will be an update
---> Package wbm-ruby-gems.noarch 2:1.6-1 will be updated
---> Package wbm-ruby-gems.noarch 2:1.7-1 will be an update
---> Package wbm-virtual-server.noarch 2:6.10.gpl-1 will be updated
---> Package wbm-virtual-server.noarch 3:6.10.gpl-2 will be an update
---> Package wbm-virtualmin-awstats.noarch 2:5.8-1 will be updated
---> Package wbm-virtualmin-awstats.noarch 2:5.9-1 will be an update
--> Processing Dependency: wbm-software for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
--> Processing Dependency: wbm-cron for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
---> Package wbm-virtualmin-dav.noarch 2:3.10-1 will be updated
---> Package wbm-virtualmin-dav.noarch 2:3.11-1 will be an update
---> Package wbm-virtualmin-git.noarch 0:1.10-1 will be updated
---> Package wbm-virtualmin-git.noarch 0:1.12-1 will be an update
--> Processing Dependency: wbm-htaccess-htpasswd for package: wbm-virtualmin-git-1.12-1.noarch
---> Package wbm-virtualmin-htpasswd.noarch 2:2.8-1 will be updated
---> Package wbm-virtualmin-htpasswd.noarch 2:2.9-1 will be an update
--> Processing Dependency: wbm-htaccess-htpasswd for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
--> Processing Dependency: wbm-apache for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
---> Package wbm-virtualmin-init.noarch 2:2.7-1 will be updated
---> Package wbm-virtualmin-init.noarch 2:2.8-1 will be an update
--> Processing Dependency: wbm-init for package: 2:wbm-virtualmin-init-2.8-1.noarch
---> Package wbm-virtualmin-registrar.noarch 2:2.7-1 will be updated
---> Package wbm-virtualmin-registrar.noarch 2:2.8-1 will be an update
---> Package wbm-virtualmin-slavedns.noarch 2:1.10-1 will be updated
---> Package wbm-virtualmin-slavedns.noarch 2:1.11-1 will be an update
--> Processing Dependency: wbm-bind8 for package: 2:wbm-virtualmin-slavedns-1.11-1.noarch
--> Finished Dependency Resolution
Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
           Requires: wbm-apache
Error: Package: 2:wbm-virtualmin-slavedns-1.11-1.noarch (virtualmin-universal)
           Requires: wbm-bind8
Error: Package: wbm-virtualmin-git-1.12-1.noarch (virtualmin-universal)
           Requires: wbm-htaccess-htpasswd
Error: Package: 2:wbm-virtualmin-init-2.8-1.noarch (virtualmin-universal)
           Requires: wbm-init
Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
           Requires: wbm-cron
Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
           Requires: wbm-htaccess-htpasswd
Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
           Requires: wbm-software
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

.. install failed!

No packages were installed. Check the messages above for the cause of the error.

same problem here on CentOS 7.8.2003. In my case I had do downgrade to gpl-1 to solve the wrong “PRO enabled” issue.

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirror.checkdomain.de
  • centos-sclo-rh: mirror.alpix.eu
  • centos-sclo-sclo: centosmirror.netcup.net
  • epel: mirrors.n-ix.net
  • extras: mirror.alpix.eu
  • remi-php73: mirror.23media.com
  • remi-safe: mirror.23media.com
  • updates: mirror.softaculous.com
    Resolving Dependencies
    –> Running transaction check
    —> Package usermin.noarch 0:1.791-1 will be updated
    —> Package usermin.noarch 0:1.802-1 will be an update
    —> Package wbm-ruby-gems.noarch 2:1.6-1 will be updated
    —> Package wbm-ruby-gems.noarch 2:1.7-1 will be an update
    —> Package wbm-virtual-server.noarch 2:6.10.gpl-1 will be updated
    —> Package wbm-virtual-server.noarch 3:6.10.gpl-2 will be an update
    —> Package wbm-virtualmin-awstats.noarch 2:5.8-1 will be updated
    —> Package wbm-virtualmin-awstats.noarch 2:5.9-1 will be an update
    –> Processing Dependency: wbm-software for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
    –> Processing Dependency: wbm-cron for package: 2:wbm-virtualmin-awstats-5.9-1.noarch
    —> Package wbm-virtualmin-dav.noarch 2:3.10-1 will be updated
    —> Package wbm-virtualmin-dav.noarch 2:3.11-1 will be an update
    —> Package wbm-virtualmin-git.noarch 0:1.10-1 will be updated
    —> Package wbm-virtualmin-git.noarch 0:1.12-1 will be an update
    –> Processing Dependency: wbm-htaccess-htpasswd for package: wbm-virtualmin-git-1.12-1.noarch
    —> Package wbm-virtualmin-htpasswd.noarch 2:2.8-1 will be updated
    —> Package wbm-virtualmin-htpasswd.noarch 2:2.9-1 will be an update
    –> Processing Dependency: wbm-htaccess-htpasswd for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
    –> Processing Dependency: wbm-apache for package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch
    —> Package wbm-virtualmin-init.noarch 2:2.7-1 will be updated
    —> Package wbm-virtualmin-init.noarch 2:2.8-1 will be an update
    –> Processing Dependency: wbm-init for package: 2:wbm-virtualmin-init-2.8-1.noarch
    —> Package wbm-virtualmin-registrar.noarch 2:2.7-1 will be updated
    —> Package wbm-virtualmin-registrar.noarch 2:2.8-1 will be an update
    —> Package wbm-virtualmin-slavedns.noarch 2:1.10-1 will be updated
    —> Package wbm-virtualmin-slavedns.noarch 2:1.11-1 will be an update
    –> Processing Dependency: wbm-bind8 for package: 2:wbm-virtualmin-slavedns-1.11-1.noarch
    –> Finished Dependency Resolution
    Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
    Requires: wbm-apache
    Error: Package: 2:wbm-virtualmin-slavedns-1.11-1.noarch (virtualmin-universal)
    Requires: wbm-bind8
    Error: Package: wbm-virtualmin-git-1.12-1.noarch (virtualmin-universal)
    Requires: wbm-htaccess-htpasswd
    Error: Package: 2:wbm-virtualmin-init-2.8-1.noarch (virtualmin-universal)
    Requires: wbm-init
    Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
    Requires: wbm-cron
    Error: Package: 2:wbm-virtualmin-htpasswd-2.9-1.noarch (virtualmin-universal)
    Requires: wbm-htaccess-htpasswd
    Error: Package: 2:wbm-virtualmin-awstats-5.9-1.noarch (virtualmin-universal)
    Requires: wbm-software
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

Please, can you fix it asap, thanks :slight_smile:

We know about it and have been working on it (see the other dozen threads where it’s being posted about). Y’all don’t have to keep reporting the same problem.

for me (on CentOS Linux 7.8.2003) it works all after a

yum clean all
yum update
1 Like

@ acor3
Confirmed, it works.

Hi,

Thanks for the heads up.

This issue has been sorted out already.

1 Like