Centos 7 - "Update Broke Virtualmin" - Fixed -DEC 2018

A Problem / Solution
maybe there are better ways to fix the same problem, In case it comes in handy how i did this.

Updated to CentOS Linux 7.6.1810 in the last few days . could not get back in to virtualmin. not even using SSH.
Im on Voltr.com - was able to see in the terminal on the dashboard “!!! Failed to load selinux policy, Freezing”
contacted surport on Vultr :
this is that

Thank you for contacting us!

There is an issue caused by a recent upgrade within CentOS. You’ll need to follow the steps below to fix the issue and restore connectivity to your instance. If you are able to log into the system using the console at my.vultr.com start at step 6. If you are not able to log into the system using the console at my.vultr.com you will need to start at step 1.

  1. Click [View Console] to access the console and click the send CTRL+ALT+DEL button on the top right. Alternatively, you can also click [RESTART] to restart the server.
    As soon as the boot process starts, press ESC to bring up the GRUB boot prompt. You may need to turn the system off from the control panel and then back on to reach the GRUB boot prompt.

  2. You will see a GRUB boot prompt - press E to edit the first boot option. (If you do not see the GRUB prompt, you may need to press any key to bring it up before the machine boots)

  3. Find the kernel line (it starts with “linux16”), change ro to rw init=/sysroot/bin/sh.

  4. Press CTRL+X or F10 to boot single user mode.

  5. Access the system with the command: chroot /sysroot

  6. Edit /etc/selinux/config and change “enforcing” to “disabled”

  7. reboot -f


but for some reason my spacebar could not work (Im Using Opera on Manjaro) - so could not do what was asked.

went and found a video that dealt with “Failed to load selinux policy, Freezing” titled " Failed to load selinux policy, Freezing | CentOS | Redhat | RHEL"
https://www.youtube.com/watch?v=YO3Vp8dZIyo
used “FIREFOX” browser instead of Opera to be able to use my spacebar in terminal to follow instructions from video.

everything came back online except “Bind” was jacked up would not start.
so i thought, fine reinstall Bind…
hmm…yep broke Bind, so that in validating the virtual domains came up with error about Bind

dug around found a 2008 article here that delt with Bind break
“BIND DNS domain : No DNS zone found for domain”
https://www.virtualmin.com/node/7999

went inside of the file manager in the Virtualmin and searched for the ( named.conf) found a file “named.config.rpmsave” compared the dates to the new file named the same, renamed the newest file to .old and renamed the named.config.rpmsave to named.config
in folder: etc/named.conf

restarted Bind service in status inside the dashboards tab “Servers Status”
reran “Validate Virtual Servers” all OK
Rebooted the server.
Backed up the server.
made and account here and typed all this. =P

good luck - cheers

sorry guys don’t know why the huge letters are showing in this post

Bind isnt loading on boot like i did before…have to start it manually now in dashboards tab "Server Status "
how do i get it load up on system boot?