Centos 7 Bridging

Not sure what is going wrong but just not getting it right, using a clean install of Centos 7 on a dedicated server and installing cloudmin gpl as well as virtualmin.

I have a main IP which is


But have also been allocated 4 other ip addresses x.x.195.148 - x.x.195.151

Network IP :x.x.195.148
Broadcast IP :x.x.195.151
Gateway IP :x.x.195.150
Netmask :

I wish to use the new range of ip’s for creating the VPS containers

Every time I try to set this up I lock myself out and then have to re install the system

Yep, me too, something is broken with bridging. Do you have remote console capability, or, a local console? I have successfully patched the network-scripts to allow it to work after Cloudmin messes it up, but, you need access.

That is, assuming I read this correctly and that you basically lose access after Cloudmin configures bridging on br0.

I am trying to create new virtual containers to use as a VPS to run web sites on but still not able to get it working.

Unfortunately I have just had a hard disk fail on another server and am having to use the one I was testing on, so have to put the idea on hold.

Has anybody got experience of setting up cloudmin on a CentOs 7 server with bridging working?

As mentioned above, I had to patch the Centos 7 network scripts after Cloudmin messed with them. Just restored a virtual WIndows on new Centos 7 host, and, the virtual Windows machine works fine. Next, I move on to other virtual machines which are Centos 6 and Centos 7.

Did you submit a bug report to Cloudmin support? I am thinking of doing so. But, I don’t recall original files and what exactly was wrong since it works now.

I have just installed on a fresh server and need to add new ip addresses. I have set 4 of them up in the - KVM Host Settings.

I am now trying to set them up on the server as they do not respond to a ping

Do I just copy the ifcfg-br0 to:


And change the ip address?

Host settings is where you put IP addresses for allocation when you create virtual servers. So, by itself, it does nothing. You would need to create some kvm virtual servers for those to become used and active.

You would not copy ifcfg-br0 to br1, etc. Each br corresponds generally to an ethernet card in the host machine. I doubt you have 5 cards? The VMs will use those addresses, or can, once you set those up.